summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasa Bodiroza <jazzva@gmail.com>2009-08-14 18:19:06 +0200
committerSasa Bodiroza <jazzva@gmail.com>2009-08-14 18:19:06 +0200
commit67416ed86c73275213c7041aaac7cd9ae832d45b (patch)
tree19ae1d13c5226ea677d7b4157b4d314b95971b23
parent284847a5dcd56240891dae3a08527e43e9d9cdfe (diff)
* xpi.mk:
- rename MOZ_XPI_EXCLUDE_FILES parameter to MOZ_XPI_DOCUMENTED_LICENSE_FILES
-rw-r--r--debian/changelog4
-rw-r--r--src/xpi.mk10
2 files changed, 7 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 05db9c4..22f24d2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -30,8 +30,8 @@ mozilla-devscripts (0.15) UNRELEASED; urgency=low
- add man/med-xpi-{pack,unpack}.1
- update src/Makefile
* xpi.mk:
- - add MOX_XPI_EXCLUDE_FILES parameter to enable exclusion of some files
- and/or directories, if needed
+ - add MOZ_XPI_DOCUMENTED_LICENSE_FILES parameter to enable exclusion of
+ extra license files during installation of the XPI to the packaging tree
-- Benjamin Drung <bdrung@ubuntu.com> Wed, 12 Aug 2009 02:21:37 +0200
diff --git a/src/xpi.mk b/src/xpi.mk
index a5882b4..99451b5 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -52,9 +52,9 @@
# usually xpi.mk creates the right links based on targetApplication
# parsed in install.rdf; if you need more directories, use this.
#
-# MOZ_XPI_EXCLUDE_FILES (OPTIONAL):
-# defines extra directories and files which should be excluded
-# during preparation of the XPI file.
+# MOZ_XPI_DOCUMENTED_LICENSE_FILES (OPTIONAL):
+# defines extra license files which need to be excluded during
+# the installation of the XPI file to the packaging tree.
#
# Deprecated variables:
#
@@ -183,8 +183,8 @@ endif
# ### general helper targets
stamp-unzip-%: $(XPI_FILE)
[ -d $(TEMPDIR) ] || mkdir -p $(TEMPDIR)
-ifneq (,$(MOZ_XPI_EXCLUDE_FILES))
- unzip -d $(TEMPDIR) $(XPI_DIR)$* -x $(MOZ_XPI_EXCLUDE_FILES)
+ifneq (,$(MOZ_XPI_DOCUMENTED_LICENSE_FILES))
+ unzip -d $(TEMPDIR) $(XPI_DIR)$* -x $(MOZ_XPI_DOCUMENTED_LICENSE_FILES)
else
unzip -d $(TEMPDIR) $(XPI_DIR)$*
endif