summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2007-12-30 22:06:35 +0100
committerFabien Tassin <fta@sofaraway.org>2007-12-30 22:06:35 +0100
commit7884069f50a78174973cc438009ffc932fae5897 (patch)
tree918df759cf8a176eeda7dea3851f55a88c6209c2
parentcda6921371822480f2d8ba86a5de34fe324b3bc6 (diff)
* Version 0.02
- update Changelog.txt and debian/changelog * Add support for thunderbird-2.0 - add src/thunderbird-2.0.mk.in
-rw-r--r--Changelog.txt3
-rw-r--r--debian/changelog4
-rw-r--r--src/thunderbird-2.0.mk.in32
3 files changed, 37 insertions, 2 deletions
diff --git a/Changelog.txt b/Changelog.txt
index a763fb5..8b42b0b 100644
--- a/Changelog.txt
+++ b/Changelog.txt
@@ -1,3 +1,6 @@
+2007/12/30 - fta - 0.02
+ - add support for thunderbird-2.0
+
2007/12/11 - fta - 0.01
- initial release after a full rewrite
- Add debian packaging
diff --git a/debian/changelog b/debian/changelog
index dd424c8..e720fc8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,5 @@
-mozilla-devscripts (0.01) UNRELEASED; urgency=low
+mozilla-devscripts (0.02) UNRELEASED; urgency=low
* Initial version
- -- Fabien Tassin <fta@sofaraway.org> Tue, 11 Dec 2007 20:00:00 +0100
+ -- Fabien Tassin <fta@sofaraway.org> Sun, 30 Dec 2007 21:06:05 +0100
diff --git a/src/thunderbird-2.0.mk.in b/src/thunderbird-2.0.mk.in
new file mode 100644
index 0000000..6c2d49a
--- /dev/null
+++ b/src/thunderbird-2.0.mk.in
@@ -0,0 +1,32 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
+# Description: Project Thunderbird 2.0
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+MOZCLIENT_TARGET := thunderbird-2.0-orig
+MOZCLIENT_APPNAME := thunderbird
+MOZCLIENT_PROJECT := mail
+MOZCLIENT_BRANCH := MOZILLA_1_8_BRANCH
+MOZCLIENT_FILE := mozilla/mail/config/version.txt
+MOZCLIENT_GETVERSION := tail -1 $(MOZCLIENT_FILE) | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_URL := 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=MOZILLA_1_8_0_BRANCH&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-12-01+00%3A00%3A00&maxdate=2017-12-10+00%3A00%3A00&cvsroot=%2Fcvsroot'
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 $(MOZCLIENT_URL) 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_EMBEDDED := 1
+MOZCLIENT_WANTMOZDIR := 1
+
+include mozclient.mk.in