summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2010-01-11 23:30:43 +0100
committerBenjamin Drung <bdrung@ubuntu.com>2010-01-11 23:30:43 +0100
commit7d5ba16f8f933d490a413e3145c20867ccde4627 (patch)
treefa243485dcd0a70f0550a802bd44b37c50d0fb0d
parent6f552eb2940efa5fc4ccc6afe924bbb1fd110daf (diff)
- create links for architecture independent extensions in /usr/share instead
of /usr/lib (Closes: #564671) - update src/install-xpi
-rw-r--r--debian/changelog5
-rwxr-xr-xsrc/install-xpi11
2 files changed, 10 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 8b0c650..97305e8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -62,6 +62,9 @@ mozilla-devscripts (0.19) UNRELEASED; urgency=low
- add --install-dir parameter to install-xpi
- update man/install-xpi.1
- update src/install-xpi
+ - create links for architecture independent extensions in /usr/share instead
+ of /usr/lib (Closes: #564671)
+ - update src/install-xpi
* moz-version:
- Add parameter for converting Mozilla versions into Debian upstream
versions and the other way round.
@@ -84,7 +87,7 @@ mozilla-devscripts (0.19) UNRELEASED; urgency=low
- update src/dh_xul-ext
- update debian/control
- -- Benjamin Drung <bdrung@ubuntu.com> Fri, 08 Jan 2010 22:49:03 +0100
+ -- Benjamin Drung <bdrung@ubuntu.com> Mon, 11 Jan 2010 23:30:25 +0100
mozilla-devscripts (0.18) unstable; urgency=low
diff --git a/src/install-xpi b/src/install-xpi
index 7396a9d..9ee6a7c 100755
--- a/src/install-xpi
+++ b/src/install-xpi
@@ -77,11 +77,11 @@ def install_xpi(script_name, package, xpi_file, exclude, install_dir, links, cor
xpi_content = zfobj.namelist()
# determine installation directory
+ if get_arch(package) == "all":
+ lib_share_dir = "share"
+ else:
+ lib_share_dir = "lib"
if install_dir is None:
- if get_arch(package) == "all":
- lib_share_dir = "share"
- else:
- lib_share_dir = "lib"
install_dir = os.path.join("usr", lib_share_dir, package)
copy_dir = os.path.join("debian", package, install_dir.strip("/"))
if verbose:
@@ -130,7 +130,8 @@ def install_xpi(script_name, package, xpi_file, exclude, install_dir, links, cor
extension_id = get_extension_id(os.path.join(copy_dir, "install.rdf"))
target_applications = get_target_applications(script_name, os.path.join(copy_dir, "install.rdf"))
for target_application in target_applications:
- destination = os.path.join("/usr/lib/mozilla/extensions/", target_application, extension_id)
+ destination = os.path.join("/usr", lib_share_dir, "mozilla/extensions",
+ target_application, extension_id)
links.add(destination)
# create symlinks