summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2009-12-02 23:28:13 +0100
committerBenjamin Drung <bdrung@ubuntu.com>2009-12-02 23:28:13 +0100
commit8a5b6aa5c3b75bf5986e9d212ad4072a63a17407 (patch)
treeff5c741e0acd13840ff49b76615ccccd094e4e62
parent1b00495bcee19050cb2fcc1e5a62959b3fdda4af (diff)
* med-xpi-{pack,unpack}:
- Drop med- prefix. - rename man/med-xpi-{pack,unpack}.1 to man/xpi-{pack,unpack}.1 - rename src/med-xpi-{pack,unpack} to src/xpi-{pack,unpack} - update README - update src/Makefile - update src/xpi.mk
-rw-r--r--README10
-rw-r--r--debian/changelog7
-rw-r--r--man/med-xpi-pack.134
-rw-r--r--man/med-xpi-unpack.134
-rw-r--r--man/xpi-pack.134
-rw-r--r--man/xpi-unpack.134
-rw-r--r--src/Makefile8
-rwxr-xr-xsrc/xpi-pack (renamed from src/med-xpi-pack)6
-rwxr-xr-xsrc/xpi-unpack (renamed from src/med-xpi-unpack)6
-rw-r--r--src/xpi.mk2
10 files changed, 91 insertions, 84 deletions
diff --git a/README b/README
index 8e4a57e..268dcdf 100644
--- a/README
+++ b/README
@@ -251,7 +251,7 @@ through launchpad.
XXX: document here!
-=== med-xpi-unpack ===
+=== xpi-unpack ===
This script unpacks XPI file to the provided output directory. After unpacking
the XPI file, it will look for JAR files in the output directory. All JAR files
@@ -260,17 +260,17 @@ unpacked to "test.jar!" directory. After unpacking, the script removes all JAR
files.
To run it, pass the name of the XPI file, and the name of the output directory:
-$ med-xpi-unpack ubufox.xpi output
+$ xpi-unpack ubufox.xpi output
In case some of the parameters are missing, input XPI file doesn't exist, or
output directory already exists, it will report an error and exit.
-=== med-xpi-pack ===
+=== xpi-pack ===
This script prepares a XPI file from the provided input directory. First, it
will look for all unpacked JAR files in the input directory. Directories with
-the unpacked JAR files have the format explained in med-xpi-unpack section. The
+the unpacked JAR files have the format explained in xpi-unpack section. The
script will pack the contents of the directory to the JAR file, named like the
JAR directory, with stripped "!" sign. For example, contents of "test.jar!" are
packed to "test.jar" file. After that, it will remove all JAR directories.
@@ -282,7 +282,7 @@ directories to the XPI file. After XPI file is produced, it will unpack all JAR
files, in order to leave intact source.
To run it, pass the name of the input directory, and the name of the XPI file:
-$ med-xpi-pack . ubufox.xpi
+$ xpi-pack . ubufox.xpi
In case some of the parameters are missing, or input directory doesn't exist,
it will report an error and exit.
diff --git a/debian/changelog b/debian/changelog
index cf13c52..39553d3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,13 @@ mozilla-devscripts (0.19) UNRELEASED; urgency=low
- correct permissions of installed files and add
MOZ_XPI_PRESERVE_PERMISSIONS to disable this behaviour (Closes: #556741)
- update src/xpi.mk
+ * med-xpi-{pack,unpack}:
+ - Drop med- prefix.
+ - rename man/med-xpi-{pack,unpack}.1 to man/xpi-{pack,unpack}.1
+ - rename src/med-xpi-{pack,unpack} to src/xpi-{pack,unpack}
+ - update README
+ - update src/Makefile
+ - update src/xpi.mk
-- Benjamin Drung <bdrung@ubuntu.com> Wed, 02 Dec 2009 23:12:35 +0100
diff --git a/man/med-xpi-pack.1 b/man/med-xpi-pack.1
deleted file mode 100644
index 4f42fdd..0000000
--- a/man/med-xpi-pack.1
+++ /dev/null
@@ -1,34 +0,0 @@
-.TH MED-XPI-PACK "1" "13 August 2009"
-
-.SH NAME
-med-xpi-pack \- pack a directory to a XPI file
-
-.SH SYNOPSIS
-\fBmed-xpi-pack\fR <\fBinput_directory\fR> <\fBoutput_XPI_file\fR>
-
-.SH DESCRIPTION
-\fBmed-xpi-pack\fR packs a directory to a XPI file. It takes in consideration the unpacked JAR files, which are unpacked during the call of med-xpi-unpack script, in order to be able to distribute them through the repositories.
-.LP
-It is distributed as a part of mozilla-devscripts package, and is automatically called during the build process of Mozilla extension package, if the package includes xpi.mk script in debian/rules file.
-
-
-.SH OPTIONS
-.TP
-None.
-
-.SH ENVIRONMENT VARIABLES
-.TP
-None.
-
-.SH EXAMPLE
-.TP
-med-xpi-pack ubufox ubufox.xpi
-Packs the contents of the directory ubufox to file ubufox.xpi.
-
-.SH SEE ALSO
-\fBmed-xpi-unpack\fR
-
-.SH AUTHOR
-\fBmed-xpi-pack\fR was written by Alexander Sack <asac@ubuntu.com> and Sasa Bodiroza <jazzva@gmail.com>, and this manual page by Sasa Bodiroza <jazzva@gmail.com>.
-
-Both are released under the GNU General Public License, version 2 or later.
diff --git a/man/med-xpi-unpack.1 b/man/med-xpi-unpack.1
deleted file mode 100644
index ef41c07..0000000
--- a/man/med-xpi-unpack.1
+++ /dev/null
@@ -1,34 +0,0 @@
-.TH MED-XPI-UNPACK "1" "13 August 2009"
-
-.SH NAME
-med-xpi-unpack \- unpack a XPI file to a directory
-
-.SH SYNOPSIS
-\fBmed-xpi-unpack\fR <\fBinput_XPI_file\fR> <\fBoutput_directory\fR>
-
-.SH DESCRIPTION
-\fBmed-xpi-pack\fR unpacks a XPI file to the specified output directory. It takes in consideration JAR files, which are usually shipped inside XPI files, and unpacks them, in order to be able to distribute them through the repositories. The unpacked JAR files are packed during build process on call of med-xpi-pack script.
-.LP
-It is distributed as a part of mozilla-devscripts package. It should be called by developer, when the XPI file needs to be unpacked during packaging.
-
-
-.SH OPTIONS
-.TP
-None.
-
-.SH ENVIRONMENT VARIABLES
-.TP
-None.
-
-.SH EXAMPLE
-.TP
-med-xpi-unpack ubufox.xpi ubufox
-Unpacks the contents of ubufox.xpi to directory ubufox.
-
-.SH SEE ALSO
-\fBmed-xpi-pack\fR
-
-.SH AUTHOR
-\fBmed-xpi-unpack\fR was written by Alexander Sack <asac@ubuntu.com> and Sasa Bodiroza <jazzva@gmail.com>, and this manual page by Sasa Bodiroza <jazzva@gmail.com>.
-
-Both are released under the GNU General Public License, version 2 or later.
diff --git a/man/xpi-pack.1 b/man/xpi-pack.1
new file mode 100644
index 0000000..e92b499
--- /dev/null
+++ b/man/xpi-pack.1
@@ -0,0 +1,34 @@
+.TH XPI-PACK "1" "13 August 2009"
+
+.SH NAME
+xpi-pack \- pack a directory to a XPI file
+
+.SH SYNOPSIS
+\fBxpi-pack\fR <\fBinput_directory\fR> <\fBoutput_XPI_file\fR>
+
+.SH DESCRIPTION
+\fBxpi-pack\fR packs a directory to a XPI file. It takes in consideration the unpacked JAR files, which are unpacked during the call of xpi-unpack script, in order to be able to distribute them through the repositories.
+.LP
+It is distributed as a part of mozilla-devscripts package, and is automatically called during the build process of Mozilla extension package, if the package includes xpi.mk script in debian/rules file.
+
+
+.SH OPTIONS
+.TP
+None.
+
+.SH ENVIRONMENT VARIABLES
+.TP
+None.
+
+.SH EXAMPLE
+.TP
+xpi-pack ubufox ubufox.xpi
+Packs the contents of the directory ubufox to file ubufox.xpi.
+
+.SH SEE ALSO
+\fBxpi-unpack\fR
+
+.SH AUTHOR
+\fBxpi-pack\fR was written by Alexander Sack <asac@ubuntu.com> and Sasa Bodiroza <jazzva@gmail.com>, and this manual page by Sasa Bodiroza <jazzva@gmail.com>.
+
+Both are released under the GNU General Public License, version 2 or later.
diff --git a/man/xpi-unpack.1 b/man/xpi-unpack.1
new file mode 100644
index 0000000..5907b95
--- /dev/null
+++ b/man/xpi-unpack.1
@@ -0,0 +1,34 @@
+.TH XPI-UNPACK "1" "13 August 2009"
+
+.SH NAME
+xpi-unpack \- unpack a XPI file to a directory
+
+.SH SYNOPSIS
+\fBxpi-unpack\fR <\fBinput_XPI_file\fR> <\fBoutput_directory\fR>
+
+.SH DESCRIPTION
+\fBxpi-pack\fR unpacks a XPI file to the specified output directory. It takes in consideration JAR files, which are usually shipped inside XPI files, and unpacks them, in order to be able to distribute them through the repositories. The unpacked JAR files are packed during build process on call of xpi-pack script.
+.LP
+It is distributed as a part of mozilla-devscripts package. It should be called by developer, when the XPI file needs to be unpacked during packaging.
+
+
+.SH OPTIONS
+.TP
+None.
+
+.SH ENVIRONMENT VARIABLES
+.TP
+None.
+
+.SH EXAMPLE
+.TP
+xpi-unpack ubufox.xpi ubufox
+Unpacks the contents of ubufox.xpi to directory ubufox.
+
+.SH SEE ALSO
+\fBxpi-pack\fR
+
+.SH AUTHOR
+\fBxpi-unpack\fR was written by Alexander Sack <asac@ubuntu.com> and Sasa Bodiroza <jazzva@gmail.com>, and this manual page by Sasa Bodiroza <jazzva@gmail.com>.
+
+Both are released under the GNU General Public License, version 2 or later.
diff --git a/src/Makefile b/src/Makefile
index 0a78d46..0660c90 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -57,8 +57,8 @@ extra_files = \
$(NULL)
bindir_files = \
- med-xpi-pack \
- med-xpi-unpack \
+ xpi-pack \
+ xpi-unpack \
moz-version
extra_dirs = \
@@ -94,8 +94,8 @@ install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(
install-man:
install -D -m 644 ../man/moz-version.1 $(DESTDIR)$(MANDIR)/man1/moz-version.1
- install -D -m 644 ../man/med-xpi-pack.1 $(DESTDIR)$(MANDIR)/man1/med-xpi-pack.1
- install -D -m 644 ../man/med-xpi-unpack.1 $(DESTDIR)$(MANDIR)/man1/med-xpi-unpack.1
+ install -D -m 644 ../man/xpi-pack.1 $(DESTDIR)$(MANDIR)/man1/xpi-pack.1
+ install -D -m 644 ../man/xpi-unpack.1 $(DESTDIR)$(MANDIR)/man1/xpi-unpack.1
clean:
rm -f $(subst_files)
diff --git a/src/med-xpi-pack b/src/xpi-pack
index 03c9b43..688839c 100755
--- a/src/med-xpi-pack
+++ b/src/xpi-pack
@@ -21,20 +21,20 @@
# ./input_dir/path/to/file.jar!/ dir. It will jar it up to
# ./input_dir/path/to/file.jar, and then remove the contents of unpacked dir.
# After that, it will zip up the contents of indir to xpi file.
-# Example: med-xpi-pack ubufox.out ubufox-ver.xpi
+# Example: xpi-pack ubufox.out ubufox-ver.xpi
INDIR=$1;
XPIFILE=$2;
usage() {
- echo "med-xpi-pack - Script to produce XPI file from input directory."
+ echo "$0 - Script to produce XPI file from input directory."
echo
echo "The output XPI file is placed in top-level of the input directory.";
echo "To place it somewhere else, provide relative or absolute path to the";
echo "output XPI file."
echo
echo "To run it call:";
- echo "$ med-xpi-pack input_directory output_xpi_file"
+ echo "$ $0 input_directory output_xpi_file"
echo
echo " input_directory - directory with the XPI source tree";
echo " output_xpi_file - name of the produced file";
diff --git a/src/med-xpi-unpack b/src/xpi-unpack
index 2b1e447..aea7d82 100755
--- a/src/med-xpi-unpack
+++ b/src/xpi-unpack
@@ -19,16 +19,16 @@
# The script unpacks the xpi file, then searches it for jar files. If it
# finds any it will unzip it to ./outpur_dir/path/to/file.jar!/ dir.
-# Example: med-xpi-unpack ubufox-ver.xpi ubufox.out
+# Example: xpi-unpack ubufox-ver.xpi ubufox.out
XPIFILE=$1;
OUTDIR=$2;
usage() {
- echo "med-xpi-unpack - Script to unpack XPI file to output directory."
+ echo "$0 - Script to unpack XPI file to output directory."
echo
echo "To run it call:";
- echo "$ med-xpi-unpack input_xpi_file output_directory"
+ echo "$ $0 input_xpi_file output_directory"
echo
echo " input_xpi_file - packed XPI source tree";
echo " output_directory - location where the unpacke XPI file is placed";
diff --git a/src/xpi.mk b/src/xpi.mk
index 680a56a..56f50b7 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -115,7 +115,7 @@ MOZ_EXTENSION_PKG ?= $(strip $(shell grep ^Package: debian/control | head -n 1 |
MOZ_XPI_ARCH := $(strip $(shell egrep '^Package:|^Architecture:' debian/control | grep -A1 '^Package:[ \t]*$(MOZ_EXTENSION_PKG)[ \t]*$$' | grep ^Architecture: | sed -e 's/Architecture://'))
-MOZ_XPI_BUILD_COMMAND ?= med-xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi
+MOZ_XPI_BUILD_COMMAND ?= xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi
XPI_RECOMMENDS = $(strip $(foreach id,$(XPI_TARGET_EMIDs), \
$(foreach package,$(packages_$(id)),$(call CHECK_VERSION,$(id),$(package)))))