summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2009-12-22 13:39:16 +0100
committerBenjamin Drung <bdrung@ubuntu.com>2009-12-22 13:39:16 +0100
commit8bb55ed5ab94e24dcde7f6eb2b5d52234b23488b (patch)
treecb69c0f183eb18f772c31505e4738b03397e42ce
parente9c6fc7700efcea66d90a82762475a05aa732a10 (diff)
- Install moz_version.py using python-support
- update debian/control - update debian/rules - update src/Makefile
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules3
-rw-r--r--src/Makefile7
4 files changed, 16 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 8aca0d7..00c368c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -26,10 +26,14 @@ mozilla-devscripts (0.19) UNRELEASED; urgency=low
- add src/dh_xul-ext
- update src/Makefile
- update src/xpi.mk
- - Move compare_versions from moz-version into separate module
+ - Move compare_versions from moz-version into separate module moz_version.py
- add src/moz_version.py
- update src/moz-version
- update src/dh_xul-ext
+ - Install moz_version.py using python-support
+ - update debian/control
+ - update debian/rules
+ - update src/Makefile
[ Alexander Sack <asac@ubuntu.com> ]
* dh_xul-ext:
@@ -39,7 +43,7 @@ mozilla-devscripts (0.19) UNRELEASED; urgency=low
- update src/dh_xul-ext
- update debian/control
- -- Benjamin Drung <bdrung@ubuntu.com> Thu, 17 Dec 2009 11:54:45 +0100
+ -- Benjamin Drung <bdrung@ubuntu.com> Tue, 22 Dec 2009 13:38:57 +0100
mozilla-devscripts (0.18) unstable; urgency=low
diff --git a/debian/control b/debian/control
index a16e6a8..599aacb 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Uploaders: Fabien Tassin <fta@ubuntu.com>,
Alexander Sack <asac@ubuntu.com>,
Benjamin Drung <bdrung@ubuntu.com>
Build-Depends: cdbs, debhelper (>= 5)
-Build-Depends-Indep: lsb-release
+Build-Depends-Indep: python, python-support
Standards-Version: 3.8.3
DM-Upload-Allowed: yes
Vcs-Bzr: lp:mozilla-devscripts
diff --git a/debian/rules b/debian/rules
index 2d6256a..c1d6454 100755
--- a/debian/rules
+++ b/debian/rules
@@ -32,3 +32,6 @@ DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(CURDIR)/debian/mozilla-devscripts/
DEB_MAKE_CHECK_TARGET := $(NULL)
DEB_INSTALL_DOCS_ALL := README
+
+install/mozilla-devscripts::
+ dh_pysupport
diff --git a/src/Makefile b/src/Makefile
index 517d03c..2939e28 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -88,7 +88,12 @@ install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(
install -m 755 -d $(DESTDIR)$(BINDIR)
install -m 755 $(bindir_files) $(DESTDIR)$(BINDIR)
for dir in $(extra_dirs) ; do \
- install -m 644 `echo $$dir/*` $(DESTDIR)$(DATADIR)/$$dir ; \
+ install -m 644 `echo $$dir/*` $(DESTDIR)$(DATADIR)/$$dir ; \
+ done
+ install -m 644 -D moz_version.py $(DESTDIR)$(DATADIR)/moz_version.py
+ for dir in $(shell pyversions -s); do \
+ mkdir -p $(DESTDIR)$(PREFIX)/lib/$$dir/site-packages/; \
+ ln -s ../../../share/mozilla-devscripts/moz_version.py $(DESTDIR)$(PREFIX)/lib/$$dir/site-packages/; \
done
find $(DESTDIR)$(DATADIR) -type f \( -name \*.pl -o -name \*.sh \) -exec chmod -v 755 {} \;
chmod 755 $(DESTDIR)$(DATADIR)/minefield-packager.mk