summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2009-09-07 22:59:37 +0200
committerBenjamin Drung <bdrung@ubuntu.com>2009-09-07 22:59:37 +0200
commit8d4a39e7e4a5467b41a281b10e6f49ef672300dd (patch)
tree3c6835fc2127b6d0576d7a8fc2a77deab97ee33c
parent15e925f58b6262bf83c9fbeff33a1ceb7e93a643 (diff)
- override files on xpi extraction (otherwise running build target would
require user interaction) - update src/xpi.mk
-rw-r--r--debian/changelog5
-rw-r--r--src/xpi.mk4
2 files changed, 6 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 7e3cb1b..b6c8db6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,8 +14,11 @@ mozilla-devscripts (0.16) UNRELEASED; urgency=low
- update src/xpi.mk
- simplify xpi-depends-stamp rule
- update src/xpi.mk
+ - override files on xpi extraction (otherwise running build target would
+ require user interaction)
+ - update src/xpi.mk
- -- Benjamin Drung <bdrung@ubuntu.com> Mon, 07 Sep 2009 22:39:31 +0200
+ -- Benjamin Drung <bdrung@ubuntu.com> Mon, 07 Sep 2009 22:59:11 +0200
mozilla-devscripts (0.15) unstable; urgency=low
diff --git a/src/xpi.mk b/src/xpi.mk
index 269fe71..d9166f7 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -189,9 +189,9 @@ install/$(MOZ_EXTENSION_PKG):: xpi-install
unzip-%-stamp: $(XPI_FILE)
[ -d $(TEMPDIR) ] || mkdir -p $(TEMPDIR)
ifneq (,$(MOZ_XPI_DOCUMENTED_LICENSE_FILES))
- unzip -d $(TEMPDIR) $(XPI_DIR)$* -x $(MOZ_XPI_DOCUMENTED_LICENSE_FILES)
+ unzip -o -d $(TEMPDIR) $(XPI_DIR)$* -x $(MOZ_XPI_DOCUMENTED_LICENSE_FILES)
else
- unzip -d $(TEMPDIR) $(XPI_DIR)$*
+ unzip -o -d $(TEMPDIR) $(XPI_DIR)$*
endif
touch $@