summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2009-08-22 14:27:34 +0200
committerBenjamin Drung <bdrung@ubuntu.com>2009-08-22 14:27:34 +0200
commit933f5304f9c11084aa1f3fdec3df4a0b9a780306 (patch)
tree245b06419bfa5b7d0d00f57974424d60b8d81dbe
parentcd45e5b5df9d545683f54296e33d1307209cca2c (diff)
- MOZ_EXTENSION_PKG is defined in either case, removing missing case handler
- update src/xpi.mk
-rw-r--r--debian/changelog4
-rw-r--r--src/xpi.mk17
2 files changed, 5 insertions, 16 deletions
diff --git a/debian/changelog b/debian/changelog
index c3076cb..01e8b52 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,8 +4,10 @@ mozilla-devscripts (0.16) UNRELEASED; urgency=low
- List all phony target and run dh_clean for all packages. These changes
makes it possible to use xpi.mk without cdbs in a simple way.
- update src/xpi.mk
+ - MOZ_EXTENSION_PKG is defined in either case, removing missing case handler
+ - update src/xpi.mk
- -- Benjamin Drung <bdrung@ubuntu.com> Sat, 22 Aug 2009 14:08:50 +0200
+ -- Benjamin Drung <bdrung@ubuntu.com> Sat, 22 Aug 2009 14:24:33 +0200
mozilla-devscripts (0.15) unstable; urgency=low
diff --git a/src/xpi.mk b/src/xpi.mk
index 0a0d0fc..68ea18d 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -143,13 +143,13 @@ CHECK_VERSION = $(shell \
moz-version -cs "$($(2)_sol)" le $(call TARGET_VERSION,$(1),maxVersion,$(TEMPDIR)) && \
echo $(2))
+MOZ_EXTENSION_PKG ?= $(strip $(shell grep ^Package: debian/control | head -n 1 | sed "s/^Package://"))
+
MOZ_XPI_BUILD_COMMAND ?= med-xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi;
XPI_DEPENDS = $(sort $(foreach id,$(call XPI_TARGET_EMIDs,$(TEMPDIR)), \
$(foreach package,$(packages_$(id)),$(call CHECK_VERSION,$(id),$(package)))))
-MOZ_EXTENSION_PKG ?= $(strip $(shell grep ^Package: debian/control | head -n 1 | sed "s/^Package://"))
-
TEMPDIR := temp-xpi-unpacked
ifneq (,$(MOZ_XPI_FILE))
@@ -219,8 +219,6 @@ stamp-xpi-depends:
mv debian/$(MOZ_EXTENSION_PKG).substvars~ debian/$(MOZ_EXTENSION_PKG).substvars
touch $@
-# only attempt to do things if a pkg was provided; otherwise error out
-ifneq (,$(MOZ_EXTENSION_PKG))
xpi-install: stamp-extension-install stamp-xpi-depends
xpi-clean:
@@ -230,15 +228,4 @@ xpi-clean:
$(NULL)
-rm -rf $(TEMPDIR)
-
-else
-xpi-install:
- echo "*** need to define MOZ_EXTENSION_PKG"
- exit 2
-
-xpi-clean:
- echo "*** need to define MOZ_EXTENSION_PKG"
- exit 2
-endif
-
.PHONY: xpi-install xpi-clean