summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Sack <asac@ubuntu.com>2009-07-29 02:08:35 +0200
committerAlexander Sack <asac@ubuntu.com>2009-07-29 02:08:35 +0200
commit93e2b6618f770cb0109906c65f619117f5bb76d9 (patch)
tree35a93aa529bd551ee6d7db56ddea271acd199ed7
parent0181a0354d7a84fd16918aafd38f771599f72101 (diff)
- add thunderbird-3.0 to list of auto detected target application packages
- update src/xpi.mk
-rw-r--r--debian/changelog4
-rw-r--r--src/xpi.mk3
2 files changed, 5 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 3d43596..f270053 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -36,7 +36,9 @@ mozilla-devscripts (0.14) UNRELEASED; urgency=low
- use moz-version-compare in ${xpi:Depends} |CHECK_VERSION| call
instead of the rather flawed dpkg --compare-versions approach.
- update src/xpi.mk
- * build-system:
+ - add thunderbird-3.0 to list of auto detected target application packages
+ - update src/xpi.mk
+ * build-system:
- add bindir_files feature and use that to install med-xpi-*pack as well as
moz-version-compare to BINDIR; in turn adjust dh_install helper
accordingly.
diff --git a/src/xpi.mk b/src/xpi.mk
index b4978a0..652b355 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -67,11 +67,12 @@ target_packages_{ec8030f7-c20a-464f-9b0e-13a3a9e97384}_3.0 := abrowser-3.0 firef
target_packages_{ec8030f7-c20a-464f-9b0e-13a3a9e97384}_3.5 := abrowser-3.5 firefox-3.5 iceweasel
target_packages_{ec8030f7-c20a-464f-9b0e-13a3a9e97384}_3.6 := abrowser-3.6 firefox-3.6
target_packages_{3550f703-e582-4d05-9a08-453d09bdfdc6}_2.0 := icedove thunderbird
+target_packages_{3550f703-e582-4d05-9a08-453d09bdfdc6}_3.0 := icedove thunderbird-3.0
target_packages_prism@developers.mozilla.org_1.0 := prism
# data for XPI_DEPENDS/CHECK_VERSION magic - targetApplication versions
target_versions_{ec8030f7-c20a-464f-9b0e-13a3a9e97384} := 3.0 3.5 3.6
-target_versions_{3550f703-e582-4d05-9a08-453d09bdfdc6} := 2.0
+target_versions_{3550f703-e582-4d05-9a08-453d09bdfdc6} := 2.0 3.0
target_versions_prism@developers.mozilla.org := 1.0
# data for XPI_DEPENDS/CHECK_VERSION magic - targetApplication min-/maxVersions