summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2007-12-16 19:57:30 +0100
committerFabien Tassin <fta@sofaraway.org>2007-12-16 19:57:30 +0100
commitc235ea34fa0e8bffa00e2571e8774d207159dbf7 (patch)
tree11b95f5916f7e59aff3079f17d1b31938cab5338
parente8dce08f2fa8a4d0683b1b3d7811107625f6cc53 (diff)
* Rename package from mozclient to mozilla-devscripts
-rw-r--r--README15
-rw-r--r--debian/changelog2
-rw-r--r--debian/control8
-rw-r--r--debian/mozclient.install1
-rw-r--r--debian/mozilla-devscripts.install1
-rwxr-xr-xdebian/rules9
-rw-r--r--src/Makefile4
-rw-r--r--src/mozclient.mk.in6
8 files changed, 23 insertions, 23 deletions
diff --git a/README b/README
index abd530f..36fb93c 100644
--- a/README
+++ b/README
@@ -1,5 +1,6 @@
-mozclient is an abstract tarball creator based on Makefile inheritance which
-provides a get-new-orig target usable by Mozilla packages in Ubuntu.
+mozilla-devscripts is an abstract tarball creator based on Makefile
+inheritance which provides a get-new-orig target usable by Mozilla packages in
+Ubuntu.
The package contains rules for the following projects:
- firefox-3.0
@@ -18,8 +19,8 @@ the "+nobinonly" signature are dropped.
To use :
-- in debian/control: add mozclient to Build-Depends
-- in debian/rules: add "include /usr/share/mozclient/yourproject.mk"
+- in debian/control: add mozilla-devscripts to Build-Depends
+- in debian/rules: add "include /usr/share/mozilla-devscripts/yourproject.mk"
The following targets are then available to the caller of debian/rules:
- get-orig-source
@@ -35,7 +36,7 @@ or
DEBIAN_TAG in the form CVS_TAG=debian_version
ex: DEBIAN_TAG=FIREFOX_3_0b2_RC1=3.0~b2~rc1
-Projects files are stored in /usr/share/mozclient as .mk files.
+Projects files are stored in /usr/share/mozilla-devscripts as .mk files.
They contain the following parameters:
- MOZCLIENT_TARGET (mandatory): a label, usually 'project-orig'
@@ -52,9 +53,9 @@ They contain the following parameters:
Example with firefox-3.0:
-- in debian/control, add mozclient to Build-Depends
+- in debian/control, add mozilla-devscripts to Build-Depends
- in debian/rules, add:
- include /usr/share/mozclient/firefox-3.0.mk
+ include /usr/share/mozilla-devscripts/firefox-3.0.mk
That's it. You've gained get-orig-source.
diff --git a/debian/changelog b/debian/changelog
index cbf1998..dd424c8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-mozclient (0.01) UNRELEASED; urgency=low
+mozilla-devscripts (0.01) UNRELEASED; urgency=low
* Initial version
diff --git a/debian/control b/debian/control
index cd0e75d..ac91ca8 100644
--- a/debian/control
+++ b/debian/control
@@ -1,16 +1,16 @@
-Source: mozclient
+Source: mozilla-devscripts
Section: devel
Priority: optional
Maintainer: Ubuntu Mozilla Team <ubuntu-mozillateam@lists.ubuntu.com>
Uploaders: Fabien Tassin <fta@sofaraway.org>
Build-Depends: debhelper (>= 5), cdbs
Standards-Version: 3.7.3
-Vcs-Bzr: https://code.launchpad.net/~mozillateam/mozclient/mozclient
+Vcs-Bzr: https://code.launchpad.net/~mozillateam/mozclient/mozclient.dev
-Package: mozclient
+Package: mozilla-devscripts
Architecture: all
Depends: cvs, wget, quilt
Description: tarball creator for Ubuntu Mozilla packages
- This package contains mozclient, an abstract tarball creator
+ This package contains mozilla-devscripts, an abstract tarball creator
based on Makefile inheritance which provides a get-new-orig target
usable by Mozilla packages in Ubuntu.
diff --git a/debian/mozclient.install b/debian/mozclient.install
deleted file mode 100644
index b11ecb5..0000000
--- a/debian/mozclient.install
+++ /dev/null
@@ -1 +0,0 @@
-debian/tmp/usr/share/mozclient
diff --git a/debian/mozilla-devscripts.install b/debian/mozilla-devscripts.install
new file mode 100644
index 0000000..525469e
--- /dev/null
+++ b/debian/mozilla-devscripts.install
@@ -0,0 +1 @@
+debian/tmp/usr/share/mozilla-devscripts
diff --git a/debian/rules b/debian/rules
index 52873db..34bdfd7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,7 +17,10 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
# 02111-1307 USA.
-DEB_SOURCE_PACKAGE = mozclient
+DEB_SOURCE_PACKAGE := $(shell dpkg-parsechangelog | sed -n 's/^Source: *\(.*\)$$/\1/ p')
+DEB_VERSION := $(shell dpkg-parsechangelog | sed -n 's/^Version: *\(.*\)$$/\1/ p')
+DEB_ISNATIVE := 1
+
DEB_INDEP_PACKAGES = $(DEB_SOURCE_PACKAGE)
DEB_ARCH_PACKAGES = $(NULL)
@@ -31,7 +34,3 @@ DEB_MAKE_CHECK_TARGET := $(NULL)
DEB_INSTALL_CHANGELOGS_ALL := Changelog.txt
DEB_INSTALL_DOCS_ALL := README
-
-DEB_VERSION := $(shell dpkg-parsechangelog | sed -n 's/^Version: *\(.*\)$$/\1/ p')
-DEB_UPSTREAM_VERSION := $(shell echo $(DEBIAN_VERSION) | sed 's/^\(.*\)-[^-]*$$/\1/')
-DEB_ISNATIVE := 1
diff --git a/src/Makefile b/src/Makefile
index cb7d22d..e20d54f 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -1,7 +1,7 @@
# -*- mode: makefile; coding: utf-8 -*-
# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
-# Description: Build system for mozclient
+# Description: Build system for mozilla-devscripts
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
@@ -20,7 +20,7 @@
PREFIX ?= /usr
-DATADIR = $(PREFIX)/share/mozclient
+DATADIR = $(PREFIX)/share/mozilla-devscripts
mk_files = \
firefox-3.0.mk \
diff --git a/src/mozclient.mk.in b/src/mozclient.mk.in
index f81fc1e..4dcc98d 100644
--- a/src/mozclient.mk.in
+++ b/src/mozclient.mk.in
@@ -1,7 +1,7 @@
# -*- mode: makefile; coding: utf-8 -*-
# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
-# Description: The core of mozclient
+# Description: The core of mozilla-devscripts
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
@@ -52,9 +52,9 @@
# Example with firefox-3.0:
#
-# - in debian/control, add mozclient to Build-Depends
+# - in debian/control, add mozilla-devscripts to Build-Depends
# - in debian/rules, add:
-# include /usr/share/mozclient/firefox-3.0.mk
+# include /usr/share/mozilla-devscripts/firefox-3.0.mk
#
# That's it. You've gained get-orig-source.
#