summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2008-06-06 17:43:15 +0200
committerFabien Tassin <fta@sofaraway.org>2008-06-06 17:43:15 +0200
commitcedab243f59823544640de7a3147e61e83750030 (patch)
tree817bb17a79b8ed45fbe0c5adc597b6bb05c9145d
parentbe5a1ab14a35ce8d409d56041eb54f63dec4972a (diff)
* [mozclient] move mozclient.pl in the mozclient directory
- src/mozclient.pl => src/mozclient/mozclient.pl - update src/Makefile - update src/mozclient.mk.in
-rw-r--r--debian/changelog14
-rw-r--r--src/Makefile1
-rw-r--r--src/mozclient.mk.in4
-rwxr-xr-xsrc/mozclient/mozclient.pl (renamed from src/mozclient.pl)0
4 files changed, 9 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index 31781ec..eb72d13 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,7 +7,7 @@ mozilla-devscripts (0.09) UNRELEASED; urgency=low
The makefile version was getting difficult to extend and to maintain.
We now have a base class called MozClient::VCS and a set of VCS classes
inheriting for it.
- - add src/mozclient.pl
+ - add src/mozclient/mozclient.pl
- add src/mozclient/${projects}.conf
- add src/mozclient/lib/MozClient/{VCS,CVS,Mercurial}.pm
- move src/patches to src/mozclient/patches
@@ -20,16 +20,16 @@ mozilla-devscripts (0.09) UNRELEASED; urgency=low
and we assign a version like nss-3.12.0.3+1.9~cvs without trailling
cvs date (as it's a taggued nss), or nss-3.12.0.3+1.9 when using a
taggued mozilla/client.mk
- - update src/mozclient.pl.in
+ - update src/mozclient/mozclient.pl
- update src/mozclient/{nspr,nss}.conf
+ change MOZCLIENT_CVS_LOC and MOZCLIENT_HG_LOC into a common
MOZCLIENT_VCS_LOC and make it mandatory
- - update src/mozclient.pl
- - update src/src/mozclient/*.conf
+ - update src/mozclient/mozclient.pl
+ - update src/mozclient/*.conf
- update README
+ add optional MOZCLIENT_SEPARATOR to specify what we want between
date and revision in the version (default to ~)
- - update src/mozclient.pl
+ - update src/mozclient/mozclient.pl
- update src/mozclient/lib/MozClient/VCS.pm
- update README
+ add support for svn
@@ -37,14 +37,14 @@ mozilla-devscripts (0.09) UNRELEASED; urgency=low
- update src/mozclient.pl
+ add a project from Prism using svn
- add src/mozclient/prism.conf
- - add src/src/prism.mk.in
+ - add src/prism.mk.in
- update src/Makefile
- update README
+ use an absolute path for remove.binonly.sh as with --conf-dir it could
be called from anywhere. Move remove.binonly.sh into mozclient
- move src/remove.binonly.sh => src/mozclient/remove.binonly.sh
- update src/Makefile
- - update src/mozclient.pl
+ - update src/mozclient/mozclient.pl
- update src/mozclient/lib/MozClient/VCS.pm
* [ compare ]
diff --git a/src/Makefile b/src/Makefile
index de2bf61..593b5b9 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -44,7 +44,6 @@ subst_files = \
extra_files = \
xpi.mk \
lp-locale-export.mk \
- mozclient.pl \
$(NULL)
extra_dirs = \
diff --git a/src/mozclient.mk.in b/src/mozclient.mk.in
index 2e7eef0..49574c9 100644
--- a/src/mozclient.mk.in
+++ b/src/mozclient.mk.in
@@ -22,9 +22,9 @@
# Don't include this file directly, include one of the project.mk
# file instead, which will include this file for you.
-MOZDEVSCRIPT_DIR = .
+MOZDEVSCRIPT_DIR = mozclient
-ifeq (.,$(MOZDEVSCRIPT_DIR))
+ifeq (mozclient,$(MOZDEVSCRIPT_DIR))
EXT=.in
endif
diff --git a/src/mozclient.pl b/src/mozclient/mozclient.pl
index 30a9722..30a9722 100755
--- a/src/mozclient.pl
+++ b/src/mozclient/mozclient.pl