summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2010-01-06 18:21:45 +0100
committerBenjamin Drung <bdrung@ubuntu.com>2010-01-06 18:21:45 +0100
commitdb17ded56bf7d52a79b6e231595d808bce6b0f51 (patch)
treed37c99cb740e453c8905672bcd4ab43825974f79
parentf0dd8d1ca336e5ca7f893d6572e145e182863ba6 (diff)
- Add "xul-ext" dh sequence
- add src/xul-ext.pm - update src/Makefile - update debian/control
-rw-r--r--debian/changelog6
-rw-r--r--debian/control1
-rw-r--r--src/Makefile2
-rw-r--r--src/xul-ext.pm8
4 files changed, 16 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 5ef771c..dcf027b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -41,6 +41,10 @@ mozilla-devscripts (0.19) UNRELEASED; urgency=low
- update debian/control
- update debian/rules
- update src/Makefile
+ - Add "xul-ext" dh sequence
+ - add src/xul-ext.pm
+ - update src/Makefile
+ - update debian/control
* install-xpi:
- Split xpi installation from xpi.mk into new install-xpi script.
- add src/install-xpi
@@ -56,7 +60,7 @@ mozilla-devscripts (0.19) UNRELEASED; urgency=low
- update src/dh_xul-ext
- update debian/control
- -- Benjamin Drung <bdrung@ubuntu.com> Wed, 06 Jan 2010 17:20:54 +0100
+ -- Benjamin Drung <bdrung@ubuntu.com> Wed, 06 Jan 2010 18:21:34 +0100
mozilla-devscripts (0.18) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 1427c67..26f3561 100644
--- a/debian/control
+++ b/debian/control
@@ -23,6 +23,7 @@ Depends: dpkg-dev,
wget,
zip,
${misc:Depends},
+ ${perl:Depends},
${python:Depends}
Suggests: cvs,
git-core,
diff --git a/src/Makefile b/src/Makefile
index 2fa0295..1b82092 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -93,6 +93,8 @@ install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(
find $(DESTDIR)$(DATADIR) -type f \( -name \*.pl -o -name \*.sh \) -exec chmod -v 755 {} \;
chmod 755 $(DESTDIR)$(DATADIR)/minefield-packager.mk
install -m 644 xul-app-data.csv.$(shell lsb_release -si) $(DESTDIR)$(DATADIR)/xul-app-data.csv
+ mkdir -p $(DESTDIR)/usr/share/perl5/Debian/Debhelper/Sequence
+ install -m 644 xul-ext.pm $(DESTDIR)/usr/share/perl5/Debian/Debhelper/Sequence/xul_ext.pm
install-man:
install -D -m 644 ../man/moz-version.1 $(DESTDIR)$(MANDIR)/man1/moz-version.1
diff --git a/src/xul-ext.pm b/src/xul-ext.pm
new file mode 100644
index 0000000..371b321
--- /dev/null
+++ b/src/xul-ext.pm
@@ -0,0 +1,8 @@
+#!/usr/bin/perl
+use warnings;
+use strict;
+use Debian::Debhelper::Dh_Lib;
+
+insert_after("dh_shlibdeps", "dh_xul-ext");
+
+1;