summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2007-12-13 18:18:54 +0100
committerFabien Tassin <fta@sofaraway.org>2007-12-13 18:18:54 +0100
commit892f8c8a7472d5aeb3302ebe0ae6169edea9ecc6 (patch)
treedbe73076eff4e9604f59db0a965ba9684afb5e90 /debian
parent67ad59d8384cd47b034b6bb420ffa152e73912a3 (diff)
* First release after a full rewrite + packaging
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control16
-rw-r--r--debian/copyright19
-rw-r--r--debian/mozclient.install1
-rwxr-xr-xdebian/rules37
6 files changed, 79 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..cbf1998
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+mozclient (0.01) UNRELEASED; urgency=low
+
+ * Initial version
+
+ -- Fabien Tassin <fta@sofaraway.org> Tue, 11 Dec 2007 20:00:00 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..cd0e75d
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: mozclient
+Section: devel
+Priority: optional
+Maintainer: Ubuntu Mozilla Team <ubuntu-mozillateam@lists.ubuntu.com>
+Uploaders: Fabien Tassin <fta@sofaraway.org>
+Build-Depends: debhelper (>= 5), cdbs
+Standards-Version: 3.7.3
+Vcs-Bzr: https://code.launchpad.net/~mozillateam/mozclient/mozclient
+
+Package: mozclient
+Architecture: all
+Depends: cvs, wget, quilt
+Description: tarball creator for Ubuntu Mozilla packages
+ This package contains mozclient, an abstract tarball creator
+ based on Makefile inheritance which provides a get-new-orig target
+ usable by Mozilla packages in Ubuntu.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..623b665
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,19 @@
+This package was debianized by Fabien Tassin <fta@sofaraway.org> on
+Tue, 11 Dec 2007 20:01:53 +0100
+
+Authors: Fabien Tassin
+
+Copyright :
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or (at
+ your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in the file /usr/share/common-licenses/GPL-2.
diff --git a/debian/mozclient.install b/debian/mozclient.install
new file mode 100644
index 0000000..b11ecb5
--- /dev/null
+++ b/debian/mozclient.install
@@ -0,0 +1 @@
+debian/tmp/usr/share/mozclient
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..52873db
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,37 @@
+#!/usr/bin/make -f
+
+# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+DEB_SOURCE_PACKAGE = mozclient
+DEB_INDEP_PACKAGES = $(DEB_SOURCE_PACKAGE)
+DEB_ARCH_PACKAGES = $(NULL)
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/makefile.mk
+
+DEB_SRCDIR := $(CURDIR)/src
+DEB_MAKE_BUILD_TARGET := build
+DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(CURDIR)/debian/tmp/
+DEB_MAKE_CHECK_TARGET := $(NULL)
+
+DEB_INSTALL_CHANGELOGS_ALL := Changelog.txt
+DEB_INSTALL_DOCS_ALL := README
+
+DEB_VERSION := $(shell dpkg-parsechangelog | sed -n 's/^Version: *\(.*\)$$/\1/ p')
+DEB_UPSTREAM_VERSION := $(shell echo $(DEBIAN_VERSION) | sed 's/^\(.*\)-[^-]*$$/\1/')
+DEB_ISNATIVE := 1