summaryrefslogtreecommitdiff
path: root/patches/nss_target.patch
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2007-09-02 23:10:22 +0000
committerFabien Tassin <fta@sofaraway.org>2007-09-02 23:10:22 +0000
commit9ea70b9aeef70cd410c9c9eafd28d14448742ca2 (patch)
tree16c252c10bd86a9f4065af5facd2d4e148ac9687 /patches/nss_target.patch
* Initial revision. Contains new targets for mozilla/client.mk, ie nss,
nspr and xulbrower.
Diffstat (limited to 'patches/nss_target.patch')
-rw-r--r--patches/nss_target.patch92
1 files changed, 92 insertions, 0 deletions
diff --git a/patches/nss_target.patch b/patches/nss_target.patch
new file mode 100644
index 0000000..2965161
--- /dev/null
+++ b/patches/nss_target.patch
@@ -0,0 +1,92 @@
+---
+ mozilla/client.mk | 16 ++++++++++------
+ 1 file changed, 10 insertions(+), 6 deletions(-)
+
+Index: mozclient/mozilla/client.mk
+===================================================================
+--- mozclient.orig/mozilla/client.mk 2007-09-02 21:01:43.000000000 +0200
++++ mozclient/mozilla/client.mk 2007-09-02 21:03:45.000000000 +0200
+@@ -53,16 +53,17 @@
+ #
+ # export CVSROOT=:pserver:anonymous:anonymous@cvs-mirror.mozilla.org:/cvsroot
+ # export CVSROOT=:pserver:username%somedomain.org@cvs.mozilla.org:/cvsroot
+ #
+ # You must specify which products/modules you wish to checkout, with
+ # MOZ_CO_PROJECT and MOZ_CO_MODULE variables.
+ #
+ # MOZ_CO_PROJECT possibilities include the following:
++# nss
+ # suite (Seamonkey suite)
+ # browser (aka Firefox)
+ # mail (aka Thunderbird)
+ # minimo (small browser for devices)
+ # composer (standalone composer, aka NVU)
+ # calendar (aka Sunbird, use this to build the calendar extensions also)
+ # xulrunner
+ # camino
+@@ -100,16 +101,17 @@
+ # MOZ_POSTFLIGHT } each project, and after all projects; these
+ # MOZ_POSTFLIGHT_ALL } variables contain space-separated lists
+ # MOZ_UNIFY_BDATE - Set to use the same bdate for each project in
+ # MOZ_BUILD_PROJECTS
+ #
+
+ AVAILABLE_PROJECTS = \
+ all \
++ nss \
+ suite \
+ toolkit \
+ browser \
+ mail \
+ minimo \
+ composer \
+ calendar \
+ xulrunner \
+@@ -139,16 +141,23 @@
+ MODULES_NS_core := \
+ $(MODULES_NS_necko) \
+ mozilla/js \
+ mozilla/js/src \
+ mozilla/js/jsd \
+ mozilla/db \
+ $(NULL)
+
++MODULES_nss := \
++ mozilla/dbm \
++ mozilla/security/nss \
++ mozilla/security/coreconf \
++ mozilla/security/dbm \
++ $(NULL)
++
+ MODULES_core := \
+ $(MODULES_necko) \
+ mozilla/caps \
+ mozilla/content \
+ mozilla/db/mdb \
+ mozilla/db/mork \
+ mozilla/docshell \
+ mozilla/dom \
+@@ -581,22 +590,17 @@
+ MOZ_MAKE := $(MAKE) $(MOZ_MAKE_FLAGS)
+ endif
+
+ endif # MOZ_BUILD_PROJECTS
+
+ ####################################
+ # CVS defines for NSS
+ #
+-NSS_CO_MODULE = \
+- mozilla/dbm \
+- mozilla/security/nss \
+- mozilla/security/coreconf \
+- mozilla/security/dbm \
+- $(NULL)
++NSS_CO_MODULE = $(MODULES_nss)
+
+ NSS_CO_FLAGS := -P
+ ifdef MOZ_CO_FLAGS
+ NSS_CO_FLAGS := $(MOZ_CO_FLAGS)
+ endif
+ NSS_CO_FLAGS := $(NSS_CO_FLAGS) $(if $(NSS_CO_TAG),-r $(NSS_CO_TAG),-A)
+
+ # Can only pull the tip or branch tags by date