summaryrefslogtreecommitdiff
path: root/src/Makefile
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2010-11-16 01:56:17 +0100
committerBenjamin Drung <bdrung@ubuntu.com>2010-11-16 01:56:17 +0100
commita0310d8d5c9034c708bec303f85cfc89c2f304f5 (patch)
treeaeb2536028d084e27129da41b1f89d95cd035eed /src/Makefile
parent396ec5e0452ca486a397cf4890f476e62d73d4c8 (diff)
* Switch from CDBS to dh 7 and simplifying packaging by improving Makefiles.
- add Makefile - update debian/compat - update debian/control - remove debian/manpages - update debian/rules - update src/Makefile
Diffstat (limited to 'src/Makefile')
-rw-r--r--src/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/src/Makefile b/src/Makefile
index b89a80a..f5f909e 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -19,8 +19,6 @@
PREFIX ?= /usr
BINDIR ?= $(PREFIX)/bin
-MANDIR ?= $(PREFIX)/share/man
-
DATADIR = $(PREFIX)/share/mozilla-devscripts
VENDOR := $(shell if dpkg-vendor --is Ubuntu || dpkg-vendor --derives-from Ubuntu; then echo "Ubuntu"; else echo "Debian"; fi)
@@ -69,6 +67,8 @@ extra_dirs = \
minefield-packager/debian \
$(NULL)
+build: $(subst_files)
+
%.mk: %.mk.in
cat $< | sed \
-e "s|^\(include\) \(.*\)\.in|\1 $(DATADIR)/\2|" \
@@ -78,11 +78,6 @@ extra_dirs = \
> $@
chmod 644 $@
-build: $(subst_files)
-
-test:
- ../tests/test-moz-version
-
install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(dir)/*))
install -m 755 -d $(DESTDIR)$(DATADIR) $(foreach dir,$(extra_dirs),$(DESTDIR)$(DATADIR)/$(dir))
install -m 644 $(subst_files) $(extra_files) $(DESTDIR)$(DATADIR)
@@ -99,10 +94,10 @@ install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(
find $(DESTDIR)$(DATADIR) -type f \( -name \*.pl -o -name \*.sh \) -exec chmod -v 755 {} \;
chmod 755 $(DESTDIR)$(DATADIR)/minefield-packager.mk
install -m 644 xul-app-data.csv.$(VENDOR) $(DESTDIR)$(DATADIR)/xul-app-data.csv
- install -D -m 644 xul-ext.pm $(DESTDIR)/usr/share/perl5/Debian/Debhelper/Sequence/xul_ext.pm
- install -D -m 644 xul-ext_build.pm $(DESTDIR)/usr/share/perl5/Debian/Debhelper/Buildsystem/xul_ext.pm
+ install -D -m 644 xul-ext.pm $(DESTDIR)$(PREFIX)/share/perl5/Debian/Debhelper/Sequence/xul_ext.pm
+ install -D -m 644 xul-ext_build.pm $(DESTDIR)$(PREFIX)/share/perl5/Debian/Debhelper/Buildsystem/xul_ext.pm
clean:
rm -f $(subst_files)
-.PHONY: clean install test
+.PHONY: clean install