summaryrefslogtreecommitdiff
path: root/src/firefox-3.0.mk.in
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2007-12-13 18:18:54 +0100
committerFabien Tassin <fta@sofaraway.org>2007-12-13 18:18:54 +0100
commit892f8c8a7472d5aeb3302ebe0ae6169edea9ecc6 (patch)
treedbe73076eff4e9604f59db0a965ba9684afb5e90 /src/firefox-3.0.mk.in
parent67ad59d8384cd47b034b6bb420ffa152e73912a3 (diff)
* First release after a full rewrite + packaging
Diffstat (limited to 'src/firefox-3.0.mk.in')
-rw-r--r--src/firefox-3.0.mk.in31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/firefox-3.0.mk.in b/src/firefox-3.0.mk.in
new file mode 100644
index 0000000..b0e65a1
--- /dev/null
+++ b/src/firefox-3.0.mk.in
@@ -0,0 +1,31 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
+# Description: Project firefox 3.0
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+MOZCLIENT_TARGET := firefox-3.0-orig
+MOZCLIENT_APPNAME := firefox-3.0
+MOZCLIENT_PROJECT := xulbrowser
+MOZCLIENT_FILE := mozilla/browser/config/version.txt
+MOZCLIENT_GETVERSION := sed -e 's/pre//; s/a\([0-9]*\)/~alpha\1/; s/b\([0-9]*\)/~b\1/' $(MOZCLIENT_FILE)
+MOZCLIENT_URL := 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyBrowser&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=week&mindate=&maxdate=&cvsroot=%2Fcvsroot'
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 $(MOZCLIENT_URL) 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_EMBEDDED := 1
+MOZCLIENT_WANTMOZDIR := 1
+
+include mozclient.mk