summaryrefslogtreecommitdiff
path: root/src/firefox-3.1.mk.in
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2008-06-02 14:02:07 +0200
committerFabien Tassin <fta@sofaraway.org>2008-06-02 14:02:07 +0200
commit68c81fa9645d3cde57e775dae4ee28c99476ea1f (patch)
tree3d5a72c74271439f5c5a2097910cacb8c2585b2a /src/firefox-3.1.mk.in
parent3df66ad3d14674a57c881e1c7b696388276676e8 (diff)
* [mozclient] Full refactoring of mozclient. It is now written in object-oriented Perl.
The makefile version was getting difficult to extend and to maintain. We now have a base class and a set of VCS classes inheriting for it. - add src/mozclient.pl.in - add src/mozclient/${projects}.conf - move src/patches to src/mozclient/patches - update src/${projects}.mk.in - update src/Makefile - update README * [mozclient] nspr and nss are now using a dynamic tag. They used to fetch HEAD which made them tricky to distribute. Now, we take NSPR_CO_TAG and NSS_CO_TAG from mozilla/client.mk (from HEAD or from a tag) and we assign a version like nss-3.12.0.3+1.9~cvs without trailling cvs date (as it's a taggued nss), or nss-3.12.0.3+1.9 when using a taggued mozilla/client.mk - update src/mozclient.pl.in - update src/mozclient/{nspr,nss}.conf
Diffstat (limited to 'src/firefox-3.1.mk.in')
-rw-r--r--src/firefox-3.1.mk.in17
1 files changed, 1 insertions, 16 deletions
diff --git a/src/firefox-3.1.mk.in b/src/firefox-3.1.mk.in
index 000e39d..74becad 100644
--- a/src/firefox-3.1.mk.in
+++ b/src/firefox-3.1.mk.in
@@ -17,22 +17,7 @@
# with this program; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-MOZCLIENT_TARGET := firefox-3.1-orig
-MOZCLIENT_APPNAME := firefox-3.1
-MOZCLIENT_PROJECT := mozilla-central
-MOZCLIENT_FILE := mozilla/browser/config/version.txt
-MOZCLIENT_GETVERSION := sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/' $(MOZCLIENT_FILE)
-MOZCLIENT_VCS := hg
-MOZCLIENT_POSTCOCMD := cd mozilla && python client.py checkout
-MOZCLIENT_URL := http://hg.mozilla.org/index.cgi/$(MOZCLIENT_PROJECT)/log
-MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 $(MOZCLIENT_URL) 2> /dev/null | \
- grep cite | head -1 | sed -e 's,.*</cite>,,' | \
- perl -e '$$m = { "Jan" => 1, "Feb" => 2, "Mar" => 3, "Apr" => 4, "May" => 5, "Jun" => 6, \
- "Jul" => 7, "Aug" => 8, "Sep" => 9, "Oct" => 10, "Nov" => 11, "Dec" => 12 } ; $$a = <>; \
- $$a =~ m/^ - \S+,\s+(\d+) (\S+) (\d+) \S+ \S+ - rev (\d+)/ && do { \
- printf "%d~%04d%02d%02d\n", $$4, $$3, $$$$m{$$2}, $$1 }; '
-MOZCLIENT_EMBEDDED := 1
-MOZCLIENT_WANTMOZDIR := 1
+MOZCLIENT_PROJECTNAME := firefox-3.1
include mozclient.mk.in