summaryrefslogtreecommitdiff
path: root/src/mozclient/mozclient.pl
diff options
context:
space:
mode:
authorFabien Tassin <fta@ubuntu.com>2009-01-19 23:24:19 +0100
committerFabien Tassin <fta@ubuntu.com>2009-01-19 23:24:19 +0100
commitfe1c29ce77a9cd7a404d3da0b9ef45e0648b7fc3 (patch)
tree984faef706a8c589ddda2d8dbb6999509091b7d9 /src/mozclient/mozclient.pl
parent728f0d60d6d5452d178f6a5ad06aa2d4a869f05a (diff)
* [mozclient] add support for local branches instead of the configured remote ones.
It is faster if you have to publish tarballs quite often from a branch, such as when doing daily snapshots. - update src/mozclient.mk.in - update src/mozclient/lib/MozClient/{CVS,Git,Mercurial,Subversion,VCS}.pm - update src/mozclient/mozclient.pl - update README
Diffstat (limited to 'src/mozclient/mozclient.pl')
-rwxr-xr-xsrc/mozclient/mozclient.pl2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mozclient/mozclient.pl b/src/mozclient/mozclient.pl
index d106231..746062e 100755
--- a/src/mozclient/mozclient.pl
+++ b/src/mozclient/mozclient.pl
@@ -79,6 +79,7 @@ mozclient [-l] project-name
--preserve-vcs|-p preserve VCS files
--embedded|-e create an embedded tarball
--modules|-m mods list of modules to fetch
+ --local-branch|-L branch use a local branch instead of the configured one
--debug|-D increase debug level
Examples:
@@ -188,6 +189,7 @@ GetOptions($opt,
'tag|t=s',
'embedded|e',
'modules|m=s',
+ 'local-branch|L=s',
'preserve-vcs|p') || &help();
&help() unless $#ARGV >= 0;