summaryrefslogtreecommitdiff
path: root/src/mozclient
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2008-06-02 14:02:07 +0200
committerFabien Tassin <fta@sofaraway.org>2008-06-02 14:02:07 +0200
commit68c81fa9645d3cde57e775dae4ee28c99476ea1f (patch)
tree3d5a72c74271439f5c5a2097910cacb8c2585b2a /src/mozclient
parent3df66ad3d14674a57c881e1c7b696388276676e8 (diff)
* [mozclient] Full refactoring of mozclient. It is now written in object-oriented Perl.
The makefile version was getting difficult to extend and to maintain. We now have a base class and a set of VCS classes inheriting for it. - add src/mozclient.pl.in - add src/mozclient/${projects}.conf - move src/patches to src/mozclient/patches - update src/${projects}.mk.in - update src/Makefile - update README * [mozclient] nspr and nss are now using a dynamic tag. They used to fetch HEAD which made them tricky to distribute. Now, we take NSPR_CO_TAG and NSS_CO_TAG from mozilla/client.mk (from HEAD or from a tag) and we assign a version like nss-3.12.0.3+1.9~cvs without trailling cvs date (as it's a taggued nss), or nss-3.12.0.3+1.9 when using a taggued mozilla/client.mk - update src/mozclient.pl.in - update src/mozclient/{nspr,nss}.conf
Diffstat (limited to 'src/mozclient')
-rw-r--r--src/mozclient/firefox-3.0-full.conf25
-rw-r--r--src/mozclient/firefox-3.0.conf26
-rw-r--r--src/mozclient/firefox-3.1.conf26
-rw-r--r--src/mozclient/firefox-4.0.conf26
-rw-r--r--src/mozclient/lightning-sunbird.conf26
-rw-r--r--src/mozclient/nspr.conf27
-rw-r--r--src/mozclient/nss.conf27
-rw-r--r--src/mozclient/patches/series1
-rw-r--r--src/mozclient/patches/xulbrowser_target.patch116
-rw-r--r--src/mozclient/seamonkey-2.0.conf24
-rw-r--r--src/mozclient/thunderbird-2.0.conf26
-rw-r--r--src/mozclient/thunderbird-3.0.conf24
-rw-r--r--src/mozclient/xulrunner-1.8.conf25
-rw-r--r--src/mozclient/xulrunner-1.9.1.conf26
-rw-r--r--src/mozclient/xulrunner-1.9.conf24
-rw-r--r--src/mozclient/xulrunner-2.0.conf26
16 files changed, 475 insertions, 0 deletions
diff --git a/src/mozclient/firefox-3.0-full.conf b/src/mozclient/firefox-3.0-full.conf
new file mode 100644
index 0000000..e4c28ad
--- /dev/null
+++ b/src/mozclient/firefox-3.0-full.conf
@@ -0,0 +1,25 @@
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
+# Project: firefox-3.0
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = firefox-3.0
+MOZCLIENT_PROJECT = browser
+MOZCLIENT_VCS = cvs
+MOZCLIENT_FILE = mozilla/browser/config/version.txt
+MOZCLIENT_GETVERSION = sed -e 's/pre//; s/a\([0-9]*\)/~alpha\1/; s/b\([0-9]*\)/~b\1/' mozilla/browser/config/version.txt
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyBrowser&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=week&mindate=&maxdate=&cvsroot=%2Fcvsroot' 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_EMBEDDED = 1
+MOZCLIENT_WANTMOZDIR = 1
diff --git a/src/mozclient/firefox-3.0.conf b/src/mozclient/firefox-3.0.conf
new file mode 100644
index 0000000..4213cc9
--- /dev/null
+++ b/src/mozclient/firefox-3.0.conf
@@ -0,0 +1,26 @@
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
+# Project: firefox-3.0
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = firefox-3.0
+MOZCLIENT_PROJECT = xulbrowser
+MOZCLIENT_VCS = cvs
+MOZCLIENT_FILE = mozilla/browser/config/version.txt
+MOZCLIENT_GETVERSION = sed -e 's/pre//; s/a\([0-9]*\)/~alpha\1/; s/b\([0-9]*\)/~b\1/' mozilla/browser/config/version.txt
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyBrowser&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=week&mindate=&maxdate=&cvsroot=%2Fcvsroot' 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_EMBEDDED = 1
+MOZCLIENT_WANTMOZDIR = 1
+MOZCLIENT_WANTPATCH = 1
diff --git a/src/mozclient/firefox-3.1.conf b/src/mozclient/firefox-3.1.conf
new file mode 100644
index 0000000..b4514bf
--- /dev/null
+++ b/src/mozclient/firefox-3.1.conf
@@ -0,0 +1,26 @@
+# Copyright (c) 2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project firefox 3.1
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = firefox-3.1
+MOZCLIENT_PROJECT = mozilla-central
+MOZCLIENT_VCS = hg
+MOZCLIENT_FILE = mozilla/browser/config/version.txt
+MOZCLIENT_GETVERSION = sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/' mozilla/browser/config/version.txt
+MOZCLIENT_POSTCOCMD = cd mozilla && python client.py checkout
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 http://hg.mozilla.org/index.cgi/mozilla-central/log 2> /dev/null | grep cite | head -1 | sed -e 's,.*</cite>,,' | perl -e '$m = { "Jan" => 1, "Feb" => 2, "Mar" => 3, "Apr" => 4, "May" => 5, "Jun" => 6, "Jul" => 7, "Aug" => 8, "Sep" => 9, "Oct" => 10, "Nov" => 11, "Dec" => 12 } ; $a = <>; $a =~ m/^ - \S+,\s+(\d+) (\S+) (\d+) \S+ \S+ - rev (\d+)/ && do { printf "%d~%04d%02d%02d\n", $4, $3, $$m{$2}, $1 }; '
+MOZCLIENT_EMBEDDED = 1
+MOZCLIENT_WANTMOZDIR = 1
diff --git a/src/mozclient/firefox-4.0.conf b/src/mozclient/firefox-4.0.conf
new file mode 100644
index 0000000..49b166e
--- /dev/null
+++ b/src/mozclient/firefox-4.0.conf
@@ -0,0 +1,26 @@
+# Copyright (c) 2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project firefox 4.0
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = firefox-4.0
+MOZCLIENT_PROJECT = mozilla-central
+MOZCLIENT_VCS = hg
+MOZCLIENT_FILE = mozilla/browser/config/version.txt
+MOZCLIENT_GETVERSION = sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/' mozilla/browser/config/version.txt
+MOZCLIENT_POSTCOCMD = cd mozilla && python client.py checkout
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 http://hg.mozilla.org/index.cgi/mozilla-central/log 2> /dev/null | grep cite | head -1 | sed -e 's,.*</cite>,,' | perl -e '$m = { "Jan" => 1, "Feb" => 2, "Mar" => 3, "Apr" => 4, "May" => 5, "Jun" => 6, "Jul" => 7, "Aug" => 8, "Sep" => 9, "Oct" => 10, "Nov" => 11, "Dec" => 12 } ; $a = <>; $a =~ m/^ - \S+,\s+(\d+) (\S+) (\d+) \S+ \S+ - rev (\d+)/ && do { printf "%d~%04d%02d%02d\n", $4, $3, $$m{$2}, $1 }; '
+MOZCLIENT_EMBEDDED = 1
+MOZCLIENT_WANTMOZDIR = 1
diff --git a/src/mozclient/lightning-sunbird.conf b/src/mozclient/lightning-sunbird.conf
new file mode 100644
index 0000000..5d5a05d
--- /dev/null
+++ b/src/mozclient/lightning-sunbird.conf
@@ -0,0 +1,26 @@
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project Sunbird 0.* (MOZILLA_1_8_BRANCH)
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = lightning-sunbird
+MOZCLIENT_PROJECT = calendar
+MOZCLIENT_BRANCH = MOZILLA_1_8_BRANCH
+MOZCLIENT_VCS = cvs
+MOZCLIENT_FILE = mozilla/calendar/sunbird/config/version.txt
+MOZCLIENT_GETVERSION = tail -1 mozilla/calendar/sunbird/config/version.txt | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=CalendarClient&branch=MOZILLA_1_8_BRANCH&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=week&mindate=&maxdate=&cvsroot=%2Fcvsroot' 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_EMBEDDED = 1
+MOZCLIENT_WANTMOZDIR = 1
diff --git a/src/mozclient/nspr.conf b/src/mozclient/nspr.conf
new file mode 100644
index 0000000..36ad1e3
--- /dev/null
+++ b/src/mozclient/nspr.conf
@@ -0,0 +1,27 @@
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
+# Project: nspr
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = nspr
+MOZCLIENT_PROJECT = # null
+MOZCLIENT_VCS = cvs
+MOZCLIENT_MODULES = mozilla/nsprpub
+MOZCLIENT_FILE = mozilla/nsprpub/pr/include/prinit.h
+MOZCLIENT_GETVERSION = ( grep -E '^\#define PR_VERSION' mozilla/nsprpub/pr/include/prinit.h | cut -d\" -f2 | tr 'A-Z' 'a-z' | sed -e 's/beta /beta/' -e 's/ */~/g' -e 's/$/+/' ; tail -1 mozilla/config/milestone.txt | sed -e 's/pre/~cvs/') | tr -d '\n'
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Fnsprpub&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=1177522884&maxdate=1588258884&cvsroot=%2Fcvsroot' 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_WANTMOZDIR = 1
+MOZCLIENT_DYNTAG_FILES = mozilla/client.mk mozilla/config/milestone.txt
+MOZCLIENT_DYNTAG = grep ^NSPR_CO_TAG mozilla/client.mk | awk '{ print $3 }'
diff --git a/src/mozclient/nss.conf b/src/mozclient/nss.conf
new file mode 100644
index 0000000..14a7a3e
--- /dev/null
+++ b/src/mozclient/nss.conf
@@ -0,0 +1,27 @@
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
+# Project: nss
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = nss
+MOZCLIENT_PROJECT = # null
+MOZCLIENT_VCS = cvs
+MOZCLIENT_MODULES = mozilla/dbm mozilla/security/coreconf mozilla/security/dbm mozilla/security/nss
+MOZCLIENT_FILE = mozilla/security/nss/lib/nss/nss.h
+MOZCLIENT_GETVERSION = ( grep '^\#define NSS_VERSION' mozilla/security/nss/lib/nss/nss.h | cut -d'"' -f2 | sed -e 's,$,+,' ; tail -1 mozilla/config/milestone.txt | sed -e 's/pre/~cvs/') | tr -d '\n'
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=NSS&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Fdbm+mozilla%2Fsecurity%2Fnss+mozilla%2Fsecurity%2Fcoreconf+mozilla%2Fsecurity%2Fdbm&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=month&mindate=&maxdate=&cvsroot=%2Fcvsroot' 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_WANTMOZDIR = 1
+MOZCLIENT_DYNTAG_FILES = mozilla/client.mk mozilla/config/milestone.txt
+MOZCLIENT_DYNTAG = grep ^NSS_CO_TAG mozilla/client.mk | awk '{ print $3 }'
diff --git a/src/mozclient/patches/series b/src/mozclient/patches/series
new file mode 100644
index 0000000..9ab520f
--- /dev/null
+++ b/src/mozclient/patches/series
@@ -0,0 +1 @@
+xulbrowser_target.patch
diff --git a/src/mozclient/patches/xulbrowser_target.patch b/src/mozclient/patches/xulbrowser_target.patch
new file mode 100644
index 0000000..5355c88
--- /dev/null
+++ b/src/mozclient/patches/xulbrowser_target.patch
@@ -0,0 +1,116 @@
+---
+ mozilla/client.mk | 38 +++++++++++++++++++++++++++++++++++---
+ 1 file changed, 35 insertions(+), 3 deletions(-)
+
+Index: mozclient-tmp/mozilla/client.mk
+===================================================================
+--- mozclient-tmp.orig/mozilla/client.mk
++++ mozclient-tmp/mozilla/client.mk
+@@ -55,16 +55,17 @@
+ # export CVSROOT=:pserver:username%somedomain.org@cvs.mozilla.org:/cvsroot
+ #
+ # You must specify which products/modules you wish to checkout, with
+ # MOZ_CO_PROJECT and MOZ_CO_MODULE variables.
+ #
+ # MOZ_CO_PROJECT possibilities include the following:
+ # suite (Seamonkey suite)
+ # browser (aka Firefox)
++# xulbrowser (aka Firefox using libxul from xulrunner)
+ # mail (aka Thunderbird)
+ # minimo (small browser for devices)
+ # composer (standalone composer, aka NVU)
+ # calendar (aka Sunbird, use this to build the calendar extensions also)
+ # xulrunner
+ # camino
+ # tamarin
+ #
+@@ -104,16 +105,17 @@
+ # MOZ_BUILD_PROJECTS
+ #
+
+ AVAILABLE_PROJECTS = \
+ all \
+ suite \
+ toolkit \
+ browser \
++ xulbrowser \
+ mail \
+ minimo \
+ composer \
+ calendar \
+ xulrunner \
+ camino \
+ necko \
+ tamarin \
+@@ -261,38 +263,68 @@
+ extensions/reporter \
+ extensions/spellcheck \
+ $(NULL)
+
+ BOOTSTRAP_suite := \
+ $(BOOTSTRAP_toolkit) \
+ $(NULL)
+
++MODULES_NS_xulbrowser := \
++ $(MODULES_NS_necko) \
++ $(NULL)
++
+ MODULES_NS_browser := \
+ $(MODULES_NS_toolkit) \
+ $(NULL)
+
++MODULES_xulbrowser := \
++ mozilla/README \
++ mozilla/config \
++ mozilla/build \
++ mozilla/intl \
++ mozilla/modules/libpref \
++ mozilla/tools/test-harness \
++ mozilla/extensions \
++ mozilla/toolkit \
++ mozilla/xpinstall \
++ mozilla/browser \
++ mozilla/probes \
++ mozilla/memory \
++ mozilla/other-licenses/branding/firefox \
++ mozilla/other-licenses/7zstub/firefox \
++ $(NULL)
++
+ MODULES_browser := \
+ $(MODULES_toolkit) \
+ mozilla/browser \
+ mozilla/other-licenses/branding/firefox \
+ mozilla/other-licenses/7zstub/firefox \
+ $(NULL)
+
+-LOCALES_browser := \
+- $(LOCALES_toolkit) \
++LOCALES_xulbrowser := \
+ browser \
+ extensions/reporter \
+ extensions/spellcheck \
+ other-licenses/branding/firefox \
+ $(NULL)
+
++LOCALES_browser := \
++ $(LOCALES_toolkit) \
++ $(LOCALES_xulbrowser) \
++ $(NULL)
++
++BOOTSTRAP_xulbrowser := \
++ mozilla/browser/config/version.txt \
++ mozilla/browser/config/mozconfig \
++ $(NULL)
++
+ BOOTSTRAP_browser := \
+ $(BOOTSTRAP_toolkit) \
+- mozilla/browser/config/mozconfig \
++ $(BOOTSTRAP_xulbrowser) \
+ $(NULL)
+
+ MODULES_NS_minimo := \
+ $(MODULES_NS_toolkit) \
+ $(NULL)
+
+ MODULES_minimo := \
+ $(MODULES_toolkit) \
diff --git a/src/mozclient/seamonkey-2.0.conf b/src/mozclient/seamonkey-2.0.conf
new file mode 100644
index 0000000..ec75a85
--- /dev/null
+++ b/src/mozclient/seamonkey-2.0.conf
@@ -0,0 +1,24 @@
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project SeaMonkey 2.0
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = seamonkey-2.0
+MOZCLIENT_PROJECT = suite
+MOZCLIENT_VCS = cvs
+MOZCLIENT_FILE = mozilla/suite/config/version.txt
+MOZCLIENT_GETVERSION = tail -1 mozilla/suite/config/version.txt | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyBrowser&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=week&mindate=&maxdate=&cvsroot=%2Fcvsroot' 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_WANTMOZDIR = 0
diff --git a/src/mozclient/thunderbird-2.0.conf b/src/mozclient/thunderbird-2.0.conf
new file mode 100644
index 0000000..e48c4cc
--- /dev/null
+++ b/src/mozclient/thunderbird-2.0.conf
@@ -0,0 +1,26 @@
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project Thunderbird 2.0
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = thunderbird
+MOZCLIENT_PROJECT = mail
+MOZCLIENT_VCS = cvs
+MOZCLIENT_BRANCH = MOZILLA_1_8_BRANCH
+MOZCLIENT_FILE = mozilla/mail/config/version.txt
+MOZCLIENT_GETVERSION = tail -1 mozilla/mail/config/version.txt | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=MOZILLA_1_8_0_BRANCH&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-12-01+00%3A00%3A00&maxdate=2017-12-10+00%3A00%3A00&cvsroot=%2Fcvsroot' 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_EMBEDDED = 1
+MOZCLIENT_WANTMOZDIR = 1
diff --git a/src/mozclient/thunderbird-3.0.conf b/src/mozclient/thunderbird-3.0.conf
new file mode 100644
index 0000000..8af133e
--- /dev/null
+++ b/src/mozclient/thunderbird-3.0.conf
@@ -0,0 +1,24 @@
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project Thunderbird 3.0
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = thunderbird-3.0
+MOZCLIENT_PROJECT = mail
+MOZCLIENT_VCS = cvs
+MOZCLIENT_FILE = mozilla/mail/config/version.txt
+MOZCLIENT_GETVERSION = tail -1 mozilla/mail/config/version.txt | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyMailNews&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=week&mindate=&maxdate=&cvsroot=%2Fcvsroot' 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_WANTMOZDIR = 1
diff --git a/src/mozclient/xulrunner-1.8.conf b/src/mozclient/xulrunner-1.8.conf
new file mode 100644
index 0000000..aefd8e2
--- /dev/null
+++ b/src/mozclient/xulrunner-1.8.conf
@@ -0,0 +1,25 @@
+# Copyright (c) 2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project XULRunner 1.8
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = xulrunner
+MOZCLIENT_PROJECT = xulrunner
+MOZCLIENT_VCS = cvs
+MOZCLIENT_BRANCH = MOZILLA_1_8_BRANCH
+MOZCLIENT_FILE = mozilla/config/milestone.txt
+MOZCLIENT_GETVERSION = tail -1 mozilla/config/milestone.txt | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyBrowser&branch=MOZILLA_1_8_BRANCH&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=week&mindate=&maxdate=&cvsroot=%2Fcvsroot' 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_WANTMOZDIR = 0
diff --git a/src/mozclient/xulrunner-1.9.1.conf b/src/mozclient/xulrunner-1.9.1.conf
new file mode 100644
index 0000000..d65aeba
--- /dev/null
+++ b/src/mozclient/xulrunner-1.9.1.conf
@@ -0,0 +1,26 @@
+# Copyright (c) 2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project XULRunner 1.9.1
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = xulrunner-1.9.1
+MOZCLIENT_PROJECT = mozilla-central
+MOZCLIENT_FILE = mozilla/config/milestone.txt
+MOZCLIENT_GETVERSION = tail -1 mozilla/config/milestone.txt | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_VCS = hg
+MOZCLIENT_POSTCOCMD = cd mozilla && python client.py checkout
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 http://hg.mozilla.org/index.cgi/mozilla-central/log 2> /dev/null | grep cite | head -1 | sed -e 's,.*</cite>,,' | perl -e '$m = { "Jan" => 1, "Feb" => 2, "Mar" => 3, "Apr" => 4, "May" => 5, "Jun" => 6, "Jul" => 7, "Aug" => 8, "Sep" => 9, "Oct" => 10, "Nov" => 11, "Dec" => 12 } ; $a = <>; $a =~ m/^ - \S+,\s+(\d+) (\S+) (\d+) \S+ \S+ - rev (\d+)/ && do { printf "%d~%04d%02d%02d\n", $4, $3, $$m{$2}, $1 }; '
+#MOZCLIENT_EMBEDDED = 1
+MOZCLIENT_WANTMOZDIR = 1
diff --git a/src/mozclient/xulrunner-1.9.conf b/src/mozclient/xulrunner-1.9.conf
new file mode 100644
index 0000000..ad67d4b
--- /dev/null
+++ b/src/mozclient/xulrunner-1.9.conf
@@ -0,0 +1,24 @@
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
+# Project: xulrunner-1.9
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = xulrunner-1.9
+MOZCLIENT_PROJECT = xulrunner
+MOZCLIENT_VCS = cvs
+MOZCLIENT_FILE = mozilla/config/milestone.txt
+MOZCLIENT_GETVERSION = tail -1 mozilla/config/milestone.txt | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyBrowser&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=week&mindate=&maxdate=&cvsroot=%2Fcvsroot' 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_WANTMOZDIR = 1
diff --git a/src/mozclient/xulrunner-2.0.conf b/src/mozclient/xulrunner-2.0.conf
new file mode 100644
index 0000000..4d4c865
--- /dev/null
+++ b/src/mozclient/xulrunner-2.0.conf
@@ -0,0 +1,26 @@
+# Copyright (c) 2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project XULRunner 2.0
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = xulrunner-2.0
+MOZCLIENT_PROJECT = mozilla-central
+MOZCLIENT_FILE = mozilla/config/milestone.txt
+MOZCLIENT_GETVERSION = tail -1 mozilla/config/milestone.txt | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_VCS = hg
+MOZCLIENT_POSTCOCMD = cd mozilla && python client.py checkout
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 http://hg.mozilla.org/index.cgi/mozilla-central/log 2> /dev/null | grep cite | head -1 | sed -e 's,.*</cite>,,' | perl -e '$m = { "Jan" => 1, "Feb" => 2, "Mar" => 3, "Apr" => 4, "May" => 5, "Jun" => 6, "Jul" => 7, "Aug" => 8, "Sep" => 9, "Oct" => 10, "Nov" => 11, "Dec" => 12 } ; $a = <>; $a =~ m/^ - \S+,\s+(\d+) (\S+) (\d+) \S+ \S+ - rev (\d+)/ && do { printf "%d~%04d%02d%02d\n", $4, $3, $$m{$2}, $1 }; '
+#MOZCLIENT_EMBEDDED = 1
+MOZCLIENT_WANTMOZDIR = 1