summaryrefslogtreecommitdiff
path: root/src/seamonkey-2.0.mk.in
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2007-12-13 18:18:54 +0100
committerFabien Tassin <fta@sofaraway.org>2007-12-13 18:18:54 +0100
commit892f8c8a7472d5aeb3302ebe0ae6169edea9ecc6 (patch)
treedbe73076eff4e9604f59db0a965ba9684afb5e90 /src/seamonkey-2.0.mk.in
parent67ad59d8384cd47b034b6bb420ffa152e73912a3 (diff)
* First release after a full rewrite + packaging
Diffstat (limited to 'src/seamonkey-2.0.mk.in')
-rw-r--r--src/seamonkey-2.0.mk.in30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/seamonkey-2.0.mk.in b/src/seamonkey-2.0.mk.in
new file mode 100644
index 0000000..b9ac04d
--- /dev/null
+++ b/src/seamonkey-2.0.mk.in
@@ -0,0 +1,30 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
+# Description: Project SeaMonkey 2.0
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+MOZCLIENT_TARGET := seamonkey-2.0.orig
+MOZCLIENT_APPNAME := seamonkey-2.0
+MOZCLIENT_PROJECT := suite
+MOZCLIENT_FILE := mozilla/suite/config/version.txt
+MOZCLIENT_GETVERSION := tail -1 $(MOZCLIENT_FILE) | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_URL := 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyBrowser&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=week&mindate=&maxdate=&cvsroot=%2Fcvsroot'
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 $(MOZCLIENT_URL) 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_WANTMOZDIR := 0
+
+include mozclient.mk