summaryrefslogtreecommitdiff
path: root/src/xpi-data-common.mk
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2009-10-06 19:02:53 +0200
committerBenjamin Drung <bdrung@ubuntu.com>2009-10-06 19:02:53 +0200
commit06e74ac9929f2c7e6e425ac862e04fb5db303036 (patch)
tree3e0eebd202b6b07427fdfab688185bca8959772f /src/xpi-data-common.mk
parent0b010ce323053e259880a980fd95026bac36b9db (diff)
- move data for the automagic detection of target application packages
into separate xpi-data-*.mk files and set default MOZ_XPI_DISTRO when installing mozilla-devscripts - rename src/xpi.mk to src/xpi.mk.in and update it - add src/xpi-data-all.mk - add src/xpi-data-common.mk - add src/xpi-data-Debian.mk - add src/xpi-data-Ubuntu.mk - update debian/control - update src/Makefile
Diffstat (limited to 'src/xpi-data-common.mk')
-rw-r--r--src/xpi-data-common.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/xpi-data-common.mk b/src/xpi-data-common.mk
new file mode 100644
index 0000000..8d984e2
--- /dev/null
+++ b/src/xpi-data-common.mk
@@ -0,0 +1,34 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2009 Canonical Ltd.
+# Author(s): Benjamin Drung <bdrung@ubuntu.com>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+ifndef _xpi_data_common
+_xpi_data_common = 1
+
+conkeror_sol := 0.9
+conkeror_eol := *
+
+xulrunner-1.9_sol := 1.9a1pre
+xulrunner-1.9_eol := 1.9.0.*
+xulrunner-1.9.1_sol := 1.9.1a1pre
+xulrunner-1.9.1_eol := 1.9.1.*
+
+packages_{a79fe89b-6662-4ff4-8e88-09950ad4dfde} += conkeror
+packages_toolkit@mozilla.org += xulrunner-1.9.1 xulrunner-1.9
+
+endif