summaryrefslogtreecommitdiff
path: root/src/xpi.mk
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2010-04-06 16:19:32 +0200
committerBenjamin Drung <bdrung@ubuntu.com>2010-04-06 16:19:32 +0200
commitd9f031708c37825bf95d3db43bf65304d5f37da2 (patch)
tree50147c0abd9218d2860ac6edaee679326a8a6b03 /src/xpi.mk
parent7dd58a382d9d8a7081b9bfc5af5a42ab9977d6bf (diff)
* install-xpi will create a system preference file in /etc; add
--disable-system-prefs to disable the new behavior (Closes: #558490, LP: #535544) - update man/install-xpi.1 - update src/install-xpi - update src/xpi.mk
Diffstat (limited to 'src/xpi.mk')
-rw-r--r--src/xpi.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index d7e8467..5ff0977 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -70,6 +70,10 @@
# This directory must be an absolute path. Use this parameter
# with care.
#
+# MOZ_XPI_DISABLE_SYSTEM_PREFS (OPTIONAL):
+# if defined (set to 1), no system preference file will be
+# created in /etc.
+#
# Unused variables (can be removed):
#
# MOZ_XPI_EMID (OPTIONAL):
@@ -93,6 +97,10 @@ ifneq (,$(MOZ_XPI_PRESERVE_PERMISSIONS))
install_xpi_extra_parameter += --preserve-permissions
endif
+ifneq (,$(MOZ_XPI_DISABLE_SYSTEM_PREFS))
+install_xpi_extra_parameter += --disable-system-prefs
+endif
+
ifneq (,$(MOZ_XPI_INSTALL_DIRECTORY))
install_xpi_extra_parameter += -i $(MOZ_XPI_INSTALL_DIRECTORY)
endif