summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2008-06-20 20:00:52 +0200
committerFabien Tassin <fta@sofaraway.org>2008-06-20 20:00:52 +0200
commit485d34782ef75498a8c617239a92ba0d00608a5b (patch)
treee6e11883782180d957f43330177a0e9d135ee113 /src
parent8241c0b0a27693301e287178f6bb468be09f7557 (diff)
* [xulapp] Add a rules file for xulrunner applications installing a build
system from the xulrunner SDK - add src/xulapp.mk - update src/Makefile
Diffstat (limited to 'src')
-rw-r--r--src/Makefile1
-rw-r--r--src/fennec.mk.in1
-rw-r--r--src/xulapp.mk.in30
3 files changed, 32 insertions, 0 deletions
diff --git a/src/Makefile b/src/Makefile
index 324bab3..23f324d 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -41,6 +41,7 @@ subst_files = \
mozclient.mk \
compare.mk \
minefield-packager.mk \
+ xulapp.mk \
$(NULL)
extra_files = \
diff --git a/src/fennec.mk.in b/src/fennec.mk.in
index 8992155..8802c69 100644
--- a/src/fennec.mk.in
+++ b/src/fennec.mk.in
@@ -20,3 +20,4 @@
MOZCLIENT_PROJECTNAME := fennec
include mozclient.mk.in
+include xulapp.mk.in
diff --git a/src/xulapp.mk.in b/src/xulapp.mk.in
new file mode 100644
index 0000000..e0eb088
--- /dev/null
+++ b/src/xulapp.mk.in
@@ -0,0 +1,30 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
+# Description: build system for xulrunner applications
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+#####################################################################
+
+XUL_VERSION := $(shell xulrunner-1.9 --gre-version)
+
+pre-build::
+ tar zxf /usr/lib/xulrunner-devel-$(XUL_VERSION)/sdk/build-system.tar.gz
+
+clean::
+ # Drop build-system files
+ rm -rf config build
+ rm -f toolkit/xre/make-platformini.py Makefile.in configure.in aclocal.m4 allmakefiles.sh nsprpub/config/make-system-wrappers.pl