summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2009-09-14 11:50:19 +0200
committerBenjamin Drung <bdrung@ubuntu.com>2009-09-14 11:50:19 +0200
commit615a1b5b7e59a37563152e812c19b8836b5dbf54 (patch)
tree76d12ee569dc9a89673195ebf98fcd358defbaba /src
parent057755976f2d8e7691b95bf26972aa1fc53961f3 (diff)
revert MOZ_XPI_PREPACKED
- update src/xpi.mk
Diffstat (limited to 'src')
-rw-r--r--src/xpi.mk9
1 files changed, 2 insertions, 7 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index b3dd629..570e124 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -44,7 +44,8 @@
# gets packaged up the standard .xpi way. Thus, the build command
# should produce an .xpi in top level directory. Note: If this
# command is specified, all .xpi files in the top level directory
-# will be removed during |clean|
+# will be removed during |clean|. If the xpi file will not be
+# build from source, you have to set this variable to nothing.
#
# MOZ_XPI_MOZILLA_EXTRA_DIRS (OPTIONAL):
# XXX: implement this!
@@ -59,10 +60,6 @@
# license files in debian/copyright appropriately. If not defined
# the common license file names are tried.
#
-# MOZ_XPI_PREPACKED (OPTIONAL):
-# set this variable to 1, if the source tarball contains the xpi
-# file and if the xpi file will not be build from source
-#
# Deprecated variables:
#
# MOZ_XPI_MOZILLA_DIRS /deprecated/ (OPTIONAL/NODEFAULT - see "Note:"):
@@ -154,9 +151,7 @@ CHECK_VERSION = $(shell \
MOZ_EXTENSION_PKG ?= $(strip $(shell grep ^Package: debian/control | head -n 1 | sed "s/^Package://"))
-ifneq ($(MOZ_XPI_PREPACKED),1)
MOZ_XPI_BUILD_COMMAND ?= med-xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi;
-endif
MOZ_XPI_DOCUMENTED_LICENSE_FILES ?= $(strip $(shell find * -iname copying -o -iname licen[cs]e -o -iname licen[cs]e.txt))