summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2009-12-02 23:28:13 +0100
committerBenjamin Drung <bdrung@ubuntu.com>2009-12-02 23:28:13 +0100
commit8a5b6aa5c3b75bf5986e9d212ad4072a63a17407 (patch)
treeff5c741e0acd13840ff49b76615ccccd094e4e62 /src
parent1b00495bcee19050cb2fcc1e5a62959b3fdda4af (diff)
* med-xpi-{pack,unpack}:
- Drop med- prefix. - rename man/med-xpi-{pack,unpack}.1 to man/xpi-{pack,unpack}.1 - rename src/med-xpi-{pack,unpack} to src/xpi-{pack,unpack} - update README - update src/Makefile - update src/xpi.mk
Diffstat (limited to 'src')
-rw-r--r--src/Makefile8
-rwxr-xr-xsrc/xpi-pack (renamed from src/med-xpi-pack)6
-rwxr-xr-xsrc/xpi-unpack (renamed from src/med-xpi-unpack)6
-rw-r--r--src/xpi.mk2
4 files changed, 11 insertions, 11 deletions
diff --git a/src/Makefile b/src/Makefile
index 0a78d46..0660c90 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -57,8 +57,8 @@ extra_files = \
$(NULL)
bindir_files = \
- med-xpi-pack \
- med-xpi-unpack \
+ xpi-pack \
+ xpi-unpack \
moz-version
extra_dirs = \
@@ -94,8 +94,8 @@ install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(
install-man:
install -D -m 644 ../man/moz-version.1 $(DESTDIR)$(MANDIR)/man1/moz-version.1
- install -D -m 644 ../man/med-xpi-pack.1 $(DESTDIR)$(MANDIR)/man1/med-xpi-pack.1
- install -D -m 644 ../man/med-xpi-unpack.1 $(DESTDIR)$(MANDIR)/man1/med-xpi-unpack.1
+ install -D -m 644 ../man/xpi-pack.1 $(DESTDIR)$(MANDIR)/man1/xpi-pack.1
+ install -D -m 644 ../man/xpi-unpack.1 $(DESTDIR)$(MANDIR)/man1/xpi-unpack.1
clean:
rm -f $(subst_files)
diff --git a/src/med-xpi-pack b/src/xpi-pack
index 03c9b43..688839c 100755
--- a/src/med-xpi-pack
+++ b/src/xpi-pack
@@ -21,20 +21,20 @@
# ./input_dir/path/to/file.jar!/ dir. It will jar it up to
# ./input_dir/path/to/file.jar, and then remove the contents of unpacked dir.
# After that, it will zip up the contents of indir to xpi file.
-# Example: med-xpi-pack ubufox.out ubufox-ver.xpi
+# Example: xpi-pack ubufox.out ubufox-ver.xpi
INDIR=$1;
XPIFILE=$2;
usage() {
- echo "med-xpi-pack - Script to produce XPI file from input directory."
+ echo "$0 - Script to produce XPI file from input directory."
echo
echo "The output XPI file is placed in top-level of the input directory.";
echo "To place it somewhere else, provide relative or absolute path to the";
echo "output XPI file."
echo
echo "To run it call:";
- echo "$ med-xpi-pack input_directory output_xpi_file"
+ echo "$ $0 input_directory output_xpi_file"
echo
echo " input_directory - directory with the XPI source tree";
echo " output_xpi_file - name of the produced file";
diff --git a/src/med-xpi-unpack b/src/xpi-unpack
index 2b1e447..aea7d82 100755
--- a/src/med-xpi-unpack
+++ b/src/xpi-unpack
@@ -19,16 +19,16 @@
# The script unpacks the xpi file, then searches it for jar files. If it
# finds any it will unzip it to ./outpur_dir/path/to/file.jar!/ dir.
-# Example: med-xpi-unpack ubufox-ver.xpi ubufox.out
+# Example: xpi-unpack ubufox-ver.xpi ubufox.out
XPIFILE=$1;
OUTDIR=$2;
usage() {
- echo "med-xpi-unpack - Script to unpack XPI file to output directory."
+ echo "$0 - Script to unpack XPI file to output directory."
echo
echo "To run it call:";
- echo "$ med-xpi-unpack input_xpi_file output_directory"
+ echo "$ $0 input_xpi_file output_directory"
echo
echo " input_xpi_file - packed XPI source tree";
echo " output_directory - location where the unpacke XPI file is placed";
diff --git a/src/xpi.mk b/src/xpi.mk
index 680a56a..56f50b7 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -115,7 +115,7 @@ MOZ_EXTENSION_PKG ?= $(strip $(shell grep ^Package: debian/control | head -n 1 |
MOZ_XPI_ARCH := $(strip $(shell egrep '^Package:|^Architecture:' debian/control | grep -A1 '^Package:[ \t]*$(MOZ_EXTENSION_PKG)[ \t]*$$' | grep ^Architecture: | sed -e 's/Architecture://'))
-MOZ_XPI_BUILD_COMMAND ?= med-xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi
+MOZ_XPI_BUILD_COMMAND ?= xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi
XPI_RECOMMENDS = $(strip $(foreach id,$(XPI_TARGET_EMIDs), \
$(foreach package,$(packages_$(id)),$(call CHECK_VERSION,$(id),$(package)))))