summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2008-06-04 15:15:49 +0200
committerFabien Tassin <fta@sofaraway.org>2008-06-04 15:15:49 +0200
commitaf5cd7aa2fc97acf626c6bfcab4aa33b5d1ab440 (patch)
tree0c761ead567b2a8171b52d2a96959e2a6a9a1f1a /src
parent68c81fa9645d3cde57e775dae4ee28c99476ea1f (diff)
* [compare] Add build-tree/dist to the list of directories for compare1
- update src/compare.mk.in
Diffstat (limited to 'src')
-rw-r--r--src/compare.mk.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/compare.mk.in b/src/compare.mk.in
index 29cb628..8cba960 100644
--- a/src/compare.mk.in
+++ b/src/compare.mk.in
@@ -46,10 +46,12 @@ compare:
@if [ "Z${COMPARE_FILTER_PRE_IN}Z" = "ZZ" ] ; then \
echo "## Can't compare dist/bin and debian/tmp (no COMPARE_FILTER_PRE_IN filter defined)" ; \
else \
- if [ -d mozilla ] ; then \
+ if [ -d mozilla/dist ] ; then \
find mozilla/dist/bin \! -type d | cut -d/ -f4- | $(COMPARE_FILTER_PRE_IN) | sort > $(LIST_BUILT) ; \
- elif [ -d build-tree/mozilla ] ; then \
+ elif [ -d build-tree/mozilla/dist ] ; then \
find build-tree/mozilla/dist/bin \! -type d | cut -d/ -f5- | $(COMPARE_FILTER_PRE_IN) | sort > $(LIST_BUILT) ; \
+ elif [ -d build-tree/dist ] ; then \
+ find build-tree/dist/bin \! -type d | cut -d/ -f4- | $(COMPARE_FILTER_PRE_IN) | sort > $(LIST_BUILT) ; \
elif [ -d dist ] ; then \
find dist/bin \! -type d | cut -d/ -f3- | $(COMPARE_FILTER_PRE_IN) | sort > $(LIST_BUILT) ; \
fi ; \