summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2008-02-29 17:05:01 +0100
committerFabien Tassin <fta@sofaraway.org>2008-02-29 17:05:01 +0100
commitc4a6a01b2eaacdaaaf68b50e31e9a0859b13e0eb (patch)
treeec5846932d5f1b32520a030f3e7d72855edc1d3b /src
parent7c020f4af6c982b401bddd332f2a5d4dc0aabc4e (diff)
* Add support for compare in thunderbird-3.0
- update src/thunderbird-3.0.mk.in
Diffstat (limited to 'src')
-rw-r--r--src/thunderbird-3.0.mk.in25
1 files changed, 24 insertions, 1 deletions
diff --git a/src/thunderbird-3.0.mk.in b/src/thunderbird-3.0.mk.in
index 8829791..98ff0a0 100644
--- a/src/thunderbird-3.0.mk.in
+++ b/src/thunderbird-3.0.mk.in
@@ -1,6 +1,6 @@
# -*- mode: makefile; coding: utf-8 -*-
-# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
# Description: Project Thunderbird 3.0
#
# This program is free software; you can redistribute it and/or
@@ -27,3 +27,26 @@ MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3
MOZCLIENT_WANTMOZDIR := 1
include mozclient.mk.in
+
+COMPARE_FILTER_PRE_IN := sed \
+ -e 's,foo,foo,' \
+ $(NULL)
+
+COMPARE_FILTER_PRE_OUT := sed \
+ -e 's,^usr/lib/thunderbird-3.0[^/]*/,,' \
+ -e 's,^usr/share/pixmaps/.*,,' \
+ $(NULL)
+
+COMPARE_FILTER_IN := sed \
+ -e 's,foo,foo,' \
+ $(NULL)
+
+COMPARE_FILTER_OUT := sed \
+ -e 's,^DEBIAN/.*,,' \
+ -e 's,^usr/lib/debug/.*,,' \
+ -e 's,^usr/share/doc/.*,,' \
+ -e 's,^usr/share/menu/.*,,' \
+ -e 's,^usr/share/applications/.*,,' \
+ $(NULL)
+
+include compare.mk.in