summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2008-03-26 01:35:02 +0100
committerFabien Tassin <fta@sofaraway.org>2008-03-26 01:35:02 +0100
commitc4b8179bd9e2da9525f104fc42953b2954094c45 (patch)
treec13fe08a7bb4fa26c743557bbc3ada482bd93faf /src
parent6c40f149b4e36d5804cfc5a6b2a5ff5496dcdf19 (diff)
* [mozclient] Add a xulrunner-1.8 project
- add src/xulrunner-1.8.mk.in - update src/Makefile
Diffstat (limited to 'src')
-rw-r--r--src/Makefile1
-rw-r--r--src/xulrunner-1.8.mk.in30
2 files changed, 31 insertions, 0 deletions
diff --git a/src/Makefile b/src/Makefile
index 4aa247e..94c5beb 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -29,6 +29,7 @@ mk_files = \
nss.mk \
seamonkey-2.0.mk \
thunderbird-3.0.mk \
+ xulrunner-1.8.mk \
xulrunner-1.9.mk \
mozclient.mk \
compare.mk \
diff --git a/src/xulrunner-1.8.mk.in b/src/xulrunner-1.8.mk.in
new file mode 100644
index 0000000..8b30b0b
--- /dev/null
+++ b/src/xulrunner-1.8.mk.in
@@ -0,0 +1,30 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project XULRunner 1.9
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_TARGET := xulrunner-1.8-orig
+MOZCLIENT_APPNAME := xulrunner
+MOZCLIENT_PROJECT := xulrunner
+MOZCLIENT_BRANCH := MOZILLA_1_8_BRANCH
+MOZCLIENT_FILE := mozilla/config/milestone.txt
+MOZCLIENT_GETVERSION := tail -1 $(MOZCLIENT_FILE) | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_URL := 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyBrowser&branch=MOZILLA_1_8_BRANCH&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=week&mindate=&maxdate=&cvsroot=%2Fcvsroot'
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 $(MOZCLIENT_URL) 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_WANTMOZDIR := 1
+
+include mozclient.mk.in