summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorFabien Tassin <fta@ubuntu.com>2008-09-20 01:25:52 +0200
committerFabien Tassin <fta@ubuntu.com>2008-09-20 01:25:52 +0200
commite9f22c8d26f2ff7b66e2a931d9fb903e929e0177 (patch)
treee980f9ffd92917369d9d4bb7e7a47854a16cb7ef /src
parent8b6053db45f3923f7072ffda57aafb546642ce6d (diff)
* [ compare ] search for $(DEB_BUILDDIR)/mozilla/dist/bin, needed
by mozilla packages using MOZ_OBJDIR - update src/compare.mk.in
Diffstat (limited to 'src')
-rw-r--r--src/compare.mk.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/compare.mk.in b/src/compare.mk.in
index 8cba960..12abcf0 100644
--- a/src/compare.mk.in
+++ b/src/compare.mk.in
@@ -54,6 +54,10 @@ compare:
find build-tree/dist/bin \! -type d | cut -d/ -f4- | $(COMPARE_FILTER_PRE_IN) | sort > $(LIST_BUILT) ; \
elif [ -d dist ] ; then \
find dist/bin \! -type d | cut -d/ -f3- | $(COMPARE_FILTER_PRE_IN) | sort > $(LIST_BUILT) ; \
+ elif [ -d $(DEB_BUILDDIR)/mozilla/dist ] ; then \
+ find $(DEB_BUILDDIR)/mozilla/dist/bin \! -type d | cut -d/ -f5- | $(COMPARE_FILTER_PRE_IN) | sort > $(LIST_BUILT) ; \
+ else \
+ echo "Error: Can't find any suitable dist/bin directory" ; \
fi ; \
find debian/tmp -type f | cut -d/ -f3- | $(COMPARE_FILTER_PRE_OUT) | sort > $(LIST_INSTALLED) ; \
echo "## Compare the content of dist/bin and debian/tmp..." ; \