summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rw-r--r--src/firefox-3.0.mk.in21
2 files changed, 23 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 8595cf3..f97024a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,9 +8,10 @@ mozilla-devscripts (0.03) UNRELEASED; urgency=low
* Rephrase documentation and document 'compare'
- update README
- update src/mozclient.mk.in
- * Add support for 'compare' in seamonkey and xulrunner
+ * Add support for 'compare' in seamonkey, firefox and xulrunner
- update src/seamonkey-2.0.mk.in
- update src/xulrunner-1.9.mk.in
+ - update src/firefox-3.0.mk.in
-- Fabien Tassin <fta@sofaraway.org> Tue, 29 Jan 2008 14:06:37 +0100
diff --git a/src/firefox-3.0.mk.in b/src/firefox-3.0.mk.in
index 99d2277..8533222 100644
--- a/src/firefox-3.0.mk.in
+++ b/src/firefox-3.0.mk.in
@@ -28,3 +28,24 @@ MOZCLIENT_EMBEDDED := 1
MOZCLIENT_WANTMOZDIR := 1
include mozclient.mk.in
+
+COMPARE_FILTER_IN := sed \
+ -e 's,^usr/lib/firefox-3.0-[^/]*/searchplugins,usr/lib/firefox-addons/searchplugins,' \
+ -e 's,^usr/lib/firefox-3.0-[^/]*/extensions/inspector@mozilla.org/.*,,' \
+ -e 's,^usr/lib/firefox-3.0-[^/]*/extensions,usr/lib/xulrunner-addons/extensions,' \
+ -e 's,^usr/lib/firefox-3.0-[^/]*/defaults/profile,etc/firefox-3.0/profile,' \
+ -e 's,^usr/lib/firefox-3.0-[^/]*/\(old-homepage-default.properties\|README.txt\|removed-files\),,' \
+ -e 's,^usr/lib/firefox-3.0-[^/]*/.autoreg,,' \
+ $(NULL)
+COMPARE_FILTER_OUT := sed \
+ -e 's,^DEBIAN/.*,,' \
+ -e 's,^usr/lib/debug/.*,,' \
+ -e 's,^usr/share/doc/.*,,' \
+ -e 's,^usr/share/applications/.*,,' \
+ -e 's,^usr/share/bug/firefox-3.0/presubj,,' \
+ -e 's,^etc/firefox-3.0/\(firefoxrc\|pref/firefox.js\),,' \
+ -e 's,^usr/lib/firefox-addons/searchplugins/\(debsearch\|wikipedia\).\(gif\|src\),,' \
+ -e 's,^usr/lib/firefox-3.0-[^/]*/\(firefox-3.0-restart-required.update-notifier\|firefox.cfg\|firefox.sh\),,' \
+ $(NULL)
+
+include compare.mk.in