summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rw-r--r--src/xpi.mk7
2 files changed, 10 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7f9e58e..05db9c4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -29,6 +29,9 @@ mozilla-devscripts (0.15) UNRELEASED; urgency=low
- wrote man page for med-xpi-{pack,unpack}
- add man/med-xpi-{pack,unpack}.1
- update src/Makefile
+ * xpi.mk:
+ - add MOX_XPI_EXCLUDE_FILES parameter to enable exclusion of some files
+ and/or directories, if needed
-- Benjamin Drung <bdrung@ubuntu.com> Wed, 12 Aug 2009 02:21:37 +0200
diff --git a/src/xpi.mk b/src/xpi.mk
index cfe2aaf..a5882b4 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -52,6 +52,9 @@
# usually xpi.mk creates the right links based on targetApplication
# parsed in install.rdf; if you need more directories, use this.
#
+# MOZ_XPI_EXCLUDE_FILES (OPTIONAL):
+# defines extra directories and files which should be excluded
+# during preparation of the XPI file.
#
# Deprecated variables:
#
@@ -180,7 +183,11 @@ endif
# ### general helper targets
stamp-unzip-%: $(XPI_FILE)
[ -d $(TEMPDIR) ] || mkdir -p $(TEMPDIR)
+ifneq (,$(MOZ_XPI_EXCLUDE_FILES))
+ unzip -d $(TEMPDIR) $(XPI_DIR)$* -x $(MOZ_XPI_EXCLUDE_FILES)
+else
unzip -d $(TEMPDIR) $(XPI_DIR)$*
+endif
touch $@
stamp-installlinks-%: