summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README1
-rw-r--r--debian/changelog5
-rw-r--r--src/Makefile1
-rw-r--r--src/mozclient/prism.conf24
-rw-r--r--src/prism.mk.in22
5 files changed, 53 insertions, 0 deletions
diff --git a/README b/README
index 3ed2301..9affe55 100644
--- a/README
+++ b/README
@@ -26,6 +26,7 @@ The package contains rules for the following projects:
- xulrunner-1.9
- xulrunner-1.9.1
- xulrunner-2.0
+ - prism
In addition there is a xpi.mk which provides standard rules/targets to package
XPI extensions for mozilla/toolkit based applications.
diff --git a/debian/changelog b/debian/changelog
index 4cfbe81..a187033 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -30,6 +30,11 @@ mozilla-devscripts (0.09) UNRELEASED; urgency=low
+ add support for svn
- add src/mozclient/lib/MozClient/Subversion.pm
- update src/mozclient.pl
+ + add a project from Prism using svn
+ - add src/mozclient/prism.conf
+ - add src/src/prism.mk.in
+ - update src/Makefile
+ - update README
* [ compare ]
+ Add build-tree/dist to the list of directories for compare1
diff --git a/src/Makefile b/src/Makefile
index bb8b1a3..d2d6dd3 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -35,6 +35,7 @@ subst_files = \
xulrunner-1.9.mk \
xulrunner-1.9.1.mk \
xulrunner-2.0.mk \
+ prism.mk \
mozclient.mk \
compare.mk \
minefield-packager.mk \
diff --git a/src/mozclient/prism.conf b/src/mozclient/prism.conf
new file mode 100644
index 0000000..67ff1f8
--- /dev/null
+++ b/src/mozclient/prism.conf
@@ -0,0 +1,24 @@
+# Copyright (c) 2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project prism
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = prism
+MOZCLIENT_PROJECT = webrunner/trunk
+MOZCLIENT_VCS = svn
+MOZCLIENT_VCS_LOC = http://svn.mozilla.org/projects
+MOZCLIENT_FILE = mozilla/confvars.sh
+MOZCLIENT_GETVERSION = grep ^MOZ_APP_VERSION= mozilla/confvars.sh | cut -d= -f2 | tr -d '\r'
+MOZCLIENT_GETDATE = svn log --limit 1 http://svn.mozilla.org/projects/webrunner/ | grep ^r | head -1 | sed -e 's/^r\([0-9]*\) | [^|]* | \([^ ]*\).*/\2r\1/' | tr -d -
diff --git a/src/prism.mk.in b/src/prism.mk.in
new file mode 100644
index 0000000..d1abe41
--- /dev/null
+++ b/src/prism.mk.in
@@ -0,0 +1,22 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project Prism
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_PROJECTNAME := prism
+
+include mozclient.mk.in