summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README2
-rw-r--r--debian/changelog10
-rw-r--r--src/mozclient.mk.in3
3 files changed, 12 insertions, 3 deletions
diff --git a/README b/README
index bc4f78e..bd93796 100644
--- a/README
+++ b/README
@@ -45,7 +45,7 @@ The following targets are then available to the caller of debian/rules:
- get-orig-source
Build a tarball according to parameters from project.mk
and optionally using either DEBIAN_DATE or DEBIAN_TAG
-- mozclient-status
+- list-tags
List all the registered CVS tags from upstream server
The caller could specify the following parameters:
diff --git a/debian/changelog b/debian/changelog
index f001995..e4498c4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,12 +1,20 @@
mozilla-devscripts (0.08) UNRELEASED; urgency=low
+ [ Alexander Sack ]
* add .NOTPARALLEL target to make mozclient.mk more reliable in parallel
make runs. We don't want parallel execution within the scope of mozclient.mk.
Maybe noteworthy that this doesn't prevent clients to invoke get-orig-source
with distinct parameters in parallel.
- update src/mozclient.mk.in
- -- Alexander Sack <asac@ubuntu.com> Sat, 12 Apr 2008 20:20:23 +0200
+ [ Fabien Tassin ]
+ * [ mozclient ]
+ + change the mozclient-status target name to list-tags easier to remember.
+ Preserve legacy mozclient-status
+ - update src/mozclient.mk.in
+ - update README
+
+ -- Fabien Tassin <fta@sofaraway.org> Sat, 19 Apr 2008 14:43:47 +0200
mozilla-devscripts (0.07) hardy; urgency=low
diff --git a/src/mozclient.mk.in b/src/mozclient.mk.in
index aac6a57..0e551b1 100644
--- a/src/mozclient.mk.in
+++ b/src/mozclient.mk.in
@@ -33,7 +33,7 @@
# - get-orig-source
# Build a tarball according to parameters from project.mk
# and optionally using either DEBIAN_DATE or DEBIAN_TAG
-# - mozclient-status
+# - list-tags
# List all the registered CVS tags from upstream server
# project.mk contains the following parameters
@@ -128,6 +128,7 @@ $(MOZ_CLIENT): mozclient-deps mozclient-dir
mozclient-client: $(MOZCLIENT_TMP)/$(MOZCLIENT_STAMP)
# List all tags
+list-tags: mozclient-status
mozclient-status: mozclient-deps mozclient-dir
cd $(MOZCLIENT_TMP) && cvs -d $(MOZCLIENT_CVS_LOC) co $(MOZCLIENT_FILE)
cd $(MOZCLIENT_TMP)/mozilla && cvs status -v $(subst mozilla/,,$(MOZCLIENT_FILE))