summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rw-r--r--src/xpi.mk13
2 files changed, 12 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 1ce2117..a4ce127 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,10 @@
mozilla-devscripts (0.27) UNRELEASED; urgency=low
* Update package lists for Debian unstable and Ubuntu oneiric.
+ * Add a MOZ_XPI_CLEAN_COMMAND to xpi.mk; thanks to Ximin Luo for the patch
+ (Closes: #632895).
- -- Benjamin Drung <bdrung@debian.org> Wed, 06 Jul 2011 10:42:09 +0200
+ -- Benjamin Drung <bdrung@debian.org> Sat, 09 Jul 2011 11:07:58 +0200
mozilla-devscripts (0.26) unstable; urgency=low
diff --git a/src/xpi.mk b/src/xpi.mk
index cd17a5c..e1324aa 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -37,9 +37,13 @@
# if defined the given command will be run _before_ the extension
# gets packaged up the standard .xpi way. Thus, the build command
# should produce an .xpi in top level directory. Note: If this
-# command is specified, all .xpi files in the top level directory
-# will be removed during |clean|. If the .xpi file will not be
-# build from source, you have to set this variable to nothing.
+# command is specified, MOZ_XPI_CLEAN_COMMAND (see below) will be
+# run during |clean|. If the .xpi file will not be build from
+# source, you have to set this variable to nothing.
+#
+# MOZ_XPI_CLEAN_COMMAND (OPTIONAL):
+# only has an effect if MOZ_XPI_BUILD_COMMAND (see above) is set.
+# It defaults to `rm -f *.xpi`.
#
# MOZ_XPI_MOZILLA_EXTRA_DIRS (OPTIONAL):
# defines extra directories to link the extension in. Usually
@@ -86,6 +90,7 @@
MOZ_EXTENSION_PKG ?= $(strip $(shell grep ^Package: debian/control | head -n 1 | sed "s/^Package://"))
MOZ_XPI_BUILD_COMMAND ?= xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi
+MOZ_XPI_CLEAN_COMMAND ?= rm -f *.xpi
ifneq (,$(MOZ_XPI_FILE))
xpi_file = $(wildcard $(MOZ_XPI_FILE))
@@ -131,7 +136,7 @@ ifneq (,$(MOZ_XPI_BUILD_COMMAND))
clean::
dh_testdir
dh_clean
- rm -f *.xpi
+ $(MOZ_XPI_CLEAN_COMMAND)
endif
.PHONY: clean xpi-install