summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--src/xpi.mk5
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b0227b8..e0ed638 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+mozilla-devscripts (0.17) UNRELEASED; urgency=low
+
+ * xpi.mk:
+ - Fail to build, if no xpi file is found.
+ - update src/xpi.mk
+
+ -- Benjamin Drung <bdrung@ubuntu.com> Tue, 06 Oct 2009 01:48:14 +0200
+
mozilla-devscripts (0.16) unstable; urgency=low
[ Benjamin Drung <bdrung@ubuntu.com> ]
diff --git a/src/xpi.mk b/src/xpi.mk
index efd5e15..fdd39ea 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -195,7 +195,7 @@ XPI_EMID = $(sort $(shell xpath -q -e '/node()/Description/em:id/text() | //RDF:
endif
ifeq (,$(MOZ_XPI_DISABLE_AUTOLINKS))
-RDF_RESOURCES = $(shell xpath -q -e '//em:targetApplication/@RDF:resource' $(1)/install.rdf | sed -e 's/.*="\(.*\)"/\1/')
+RDF_RESOURCES = $(shell xpath -q -e '//em:targetApplication/@RDF:resource' $(1)/install.rdf 2>/dev/null | sed -e 's/.*="\(.*\)"/\1/')
XPI_TARGET_EMIDs = \
$(shell xpath -q -e '//em:targetApplication//@em:id' $(1)/install.rdf 2>/dev/null | sed -e 's/.*"\(.*\)"/\1/') \
@@ -243,6 +243,9 @@ installlinks-%-stamp: $(patsubst %,unzip-%-stamp,$(XPI_BASE_FILE))
touch $@
autolinks-stamp: $(patsubst %,unzip-%-stamp,$(XPI_BASE_FILE)) $(foreach mozilla,$(MOZ_XPI_MOZILLA_DIRS),installlinks-$(mozilla)-stamp)
+ $(if $(XPI_FILE),,@echo "xpi.mk: No xpi file found. Did you create one?"; \
+ echo "xpi.mk: Please check MOZ_XPI_BUILD_COMMAND and maybe MOZ_XPI_FILE!"; \
+ exit 2)
$(foreach id,$(call XPI_TARGET_EMIDs,$(TEMPDIR)),dh_link -p$(MOZ_EXTENSION_PKG) /usr/$(lib_share_dir)/$(MOZ_EXTENSION_PKG) /usr/lib/mozilla/extensions/$(id)/$(call XPI_EMID,$(TEMPDIR));)
touch $@