summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xsrc/install-xpi14
2 files changed, 3 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index db3c9fa..46b040a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,8 +6,10 @@ mozilla-devscripts (0.25) UNRELEASED; urgency=low
* Update package list for Debian experimental and Ubuntu natty.
- update src/xul-app-data.csv.Debian
- update src/xul-app-data.csv.Ubuntu
+ * Drop backwards compatibility for Icedove/Thunderbird << 3.0.
+ - update src/install-xpi
- -- Benjamin Drung <bdrung@ubuntu.com> Mon, 15 Nov 2010 23:38:17 +0100
+ -- Benjamin Drung <bdrung@ubuntu.com> Tue, 16 Nov 2010 00:07:17 +0100
mozilla-devscripts (0.24) unstable; urgency=low
diff --git a/src/install-xpi b/src/install-xpi
index 1235047..0e547eb 100755
--- a/src/install-xpi
+++ b/src/install-xpi
@@ -78,15 +78,6 @@ def get_xul_apps():
rows.append(row)
return rows
-def incompatible_apps(target_applications):
- """There are still some application that do not scan
- "/usr/{lib,share}/mozilla/extensions/$target_application" for extensions."""
- xul_apps = filter(lambda x: x["id"] in target_applications, get_xul_apps())
- app_list = reduce(lambda l, x: l + [x["package"]], xul_apps, list())
- incompatible_apps = ["icedove", "thunderbird"]
- incompatible_apps = filter(lambda x: x in app_list, incompatible_apps)
- return incompatible_apps
-
def install_xpi(script_name, package, xpi_file, exclude, install_dir, links,
correct_permissions, remove_licenses, system_prefs, verbose=False):
# get xpi file content list
@@ -185,11 +176,6 @@ def install_xpi(script_name, package, xpi_file, exclude, install_dir, links,
target_application, extension_id)
links.add(destination)
- # backwards compatibility: create symlinks for applications that do not
- # scan /usr/{lib,share}/mozilla/extensions/target_application for extensions
- for app in incompatible_apps(target_applications):
- links.add(os.path.join("/usr/lib", app, "extensions", extension_id))
-
# create symlinks
for link in links:
command = ["dh_link", "-p" + package, install_dir, link]