summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README3
-rw-r--r--debian/changelog8
-rw-r--r--src/xpi.mk7
3 files changed, 12 insertions, 6 deletions
diff --git a/README b/README
index 4fce592..32e716d 100644
--- a/README
+++ b/README
@@ -196,7 +196,8 @@ parameters:
- use the given command _before_ running the normal
|install-xpi| procedure. This parameter is useful for all
those extension sources that have a command/make target
- to produce a XPI.
+ to produce a XPI. If a developer doesn't provide the
+ command, the default one will be used.
MOZ_XPI_MOZILLA_DIRS
- link the extension to the global |extensions| directory
of the given MOZILLAs. The default value is |firefox| and
diff --git a/debian/changelog b/debian/changelog
index e3f8ce1..c14e874 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,7 +3,13 @@ mozilla-devscripts (0.10) UNRELEASED; urgency=low
* Open tree for 0.10 development.
* Add src/med-xpi-{pack,unpack} scripts to manage packing and unpacking of
XPI files.
- * Document src/med-xpi-{pack,unpack} scripts in README
+ * In src/xpi.mk:
+ - Add default build command.
+ - Remove part of clean target, which checks if build command is defined,
+ because now we always have a build command (default, or provided by dev).
+ * In README:
+ - Document src/med-xpi-{pack,unpack} scripts.
+ - Document default build command in xpi.mk part.
* Add zip to Depends in debian/control, because src/med-xpi-{pack,unpack}
scripts need it.
* Add src/med-xpi-{pack,unpack} to debian/mozilla-devscripts.install to
diff --git a/src/xpi.mk b/src/xpi.mk
index 8f2a5ac..5fb3583 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -51,6 +51,8 @@
MOZ_XPI_MOZILLA_DIRS ?= firefox-addons firefox
+MOZ_XPI_BUILD_COMMAND ?= rm -f `pwd`/*.xpi ; med-xpi-pack `pwd` $(MOZ_EXTENSION_PKG).xpi;
+
TEMPDIR := $(shell rm -rf temp-xpi-*; mktemp -d temp-xpi-XXXXXXXX)
ifneq (,$(MOZ_XPI_FILE))
@@ -74,11 +76,8 @@ endif
install/$(MOZ_EXTENSION_PKG):: xpi-install
-# clean build and remove all .xpi in top-level if a MOZ_XPI_BUILD_COMMAND is defined
+# clean build
clean:: xpi-clean
-ifneq (,$(MOZ_XPI_BUILD_COMMAND))
- rm -f *.xpi
-endif
# ### general helper targets
stamp-unzip-%: