summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--src/Makefile1
-rw-r--r--src/fennec.mk.in1
-rw-r--r--src/xulapp.mk.in30
4 files changed, 38 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 9c7dda2..fd848c0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -86,6 +86,12 @@ mozilla-devscripts (0.09) UNRELEASED; urgency=low
+ add support for flock
- update src/flock.mk.in
+ * [ xulapp ]
+ + Add a rules file for xulrunner applications installing a build
+ system from the xulrunner SDK
+ - add src/xulapp.mk
+ - update src/Makefile
+
-- Fabien Tassin <fta@sofaraway.org> Fri, 30 May 2008 15:36:16 +0200
mozilla-devscripts (0.08.1) intrepid; urgency=low
diff --git a/src/Makefile b/src/Makefile
index 324bab3..23f324d 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -41,6 +41,7 @@ subst_files = \
mozclient.mk \
compare.mk \
minefield-packager.mk \
+ xulapp.mk \
$(NULL)
extra_files = \
diff --git a/src/fennec.mk.in b/src/fennec.mk.in
index 8992155..8802c69 100644
--- a/src/fennec.mk.in
+++ b/src/fennec.mk.in
@@ -20,3 +20,4 @@
MOZCLIENT_PROJECTNAME := fennec
include mozclient.mk.in
+include xulapp.mk.in
diff --git a/src/xulapp.mk.in b/src/xulapp.mk.in
new file mode 100644
index 0000000..e0eb088
--- /dev/null
+++ b/src/xulapp.mk.in
@@ -0,0 +1,30 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
+# Description: build system for xulrunner applications
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+#####################################################################
+
+XUL_VERSION := $(shell xulrunner-1.9 --gre-version)
+
+pre-build::
+ tar zxf /usr/lib/xulrunner-devel-$(XUL_VERSION)/sdk/build-system.tar.gz
+
+clean::
+ # Drop build-system files
+ rm -rf config build
+ rm -f toolkit/xre/make-platformini.py Makefile.in configure.in aclocal.m4 allmakefiles.sh nsprpub/config/make-system-wrappers.pl