summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rw-r--r--src/mozclient/lib/MozClient/Mercurial.pm4
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 7cd87dd..4d3b3a6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -16,6 +16,8 @@ mozilla-devscripts (0.10) UNRELEASED; urgency=low
* Change Recommends into Suggests for cvs and mercurial as those are
not needed to use mozilla-devscripts as a build-dependency.
- update debian/control
+ * [mozclient] fix Mercurial tags not passed during checkout
+ - update src/mozclient/lib/MozClient/Mercurial.pm
[ Alexander Sack <asac@ubuntu.com> ]
* inject awesome-browser branding into firefox source tree by
diff --git a/src/mozclient/lib/MozClient/Mercurial.pm b/src/mozclient/lib/MozClient/Mercurial.pm
index 95176c9..45fcbbc 100644
--- a/src/mozclient/lib/MozClient/Mercurial.pm
+++ b/src/mozclient/lib/MozClient/Mercurial.pm
@@ -78,8 +78,8 @@ sub checkout {
$self->{'MOZCLIENT_PROJECT'}, $module);
}
}
- my $cmd = sprintf "hg clone %s %s %s", $self->{'mozclient_date'},
- join(" ", @$modules), $self->{'MOZCLIENT_MOZDIRNAME'};
+ my $cmd = sprintf "hg clone %s %s %s %s", $self->{'mozclient_date'},
+ $self->{'co_tag'}, join(" ", @$modules), $self->{'MOZCLIENT_MOZDIRNAME'};
$self->run_system($cmd);
$self->chdir("..");
}