summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rwxr-xr-xsrc/install-xpi3
2 files changed, 6 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 7f9c4cc..6051f8e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,8 +11,11 @@ mozilla-devscripts (0.21) UNRELEASED; urgency=low
- add man/xpi-repack.1
- add src/xpi-repack
- update src/Makefile
+ * Install extensions into xul-ext subdirectory; thanks to Daniel Kahn Gillmor
+ for the patch.
+ - update src/install-xpi
- -- Benjamin Drung <bdrung@ubuntu.com> Wed, 10 Mar 2010 18:02:17 +0100
+ -- Benjamin Drung <bdrung@ubuntu.com> Wed, 17 Mar 2010 11:37:57 +0100
mozilla-devscripts (0.20) unstable; urgency=low
diff --git a/src/install-xpi b/src/install-xpi
index ade3f73..4fc6013 100755
--- a/src/install-xpi
+++ b/src/install-xpi
@@ -100,7 +100,8 @@ def install_xpi(script_name, package, xpi_file, exclude, install_dir, links, cor
else:
lib_share_dir = "lib"
if install_dir is None:
- install_dir = os.path.join("usr", lib_share_dir, package)
+ install_dir = os.path.join("usr", lib_share_dir, "xul-ext",
+ package.replace("xul-ext-", ""))
copy_dir = os.path.join("debian", package, install_dir.strip("/"))
if verbose:
print "%s: install directory: %s" % (script_name, install_dir)