summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rw-r--r--src/mozclient/flock-remove.binonly.sh31
2 files changed, 34 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index b08096d..eb7f604 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -32,12 +32,15 @@ mozilla-devscripts (0.09) UNRELEASED; urgency=low
- update src/mozclient/mozclient.pl
- update src/mozclient/lib/MozClient/VCS.pm
- update README
+ + run an optional package specific clean-up script. It should be called
+ src/mozclient/${pkg_name}-remove.binonly.sh
+ add support for svn
- add src/mozclient/lib/MozClient/Subversion.pm
- update src/mozclient.pl
+ add projects for Prism and Flock using svn
- add src/mozclient/{prism,flock}.conf
- add src/{prism,flock}.mk.in
+ - add src/mozclient/flock-remove.binonly.sh
- update src/Makefile
- update README
+ use an absolute path for remove.binonly.sh as with --conf-dir it could
@@ -51,8 +54,6 @@ mozilla-devscripts (0.09) UNRELEASED; urgency=low
- update src/mozclient/lib/MozClient/VCS.pm
- update src/mozclient/mozclient.pl
- update README
- + run an optional package specific clean-up script. It should be called
- src/mozclient/${pkg_name}-remove.binonly.sh
- update src/mozclient/lib/MozClient/VCS.pm
* [ compare ]
diff --git a/src/mozclient/flock-remove.binonly.sh b/src/mozclient/flock-remove.binonly.sh
new file mode 100644
index 0000000..569bce1
--- /dev/null
+++ b/src/mozclient/flock-remove.binonly.sh
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+rm -fv ./other-licenses/branding/Sulfur/nsi-installer/install_flash_player.exe
+rm -fv ./other-licenses/branding/Sulfur/nsi-installer/SetBrowser.EXE
+rm -fv ./other-licenses/branding/Sulfur/nsi-installer/FLset.exe
+rm -fv ./other-licenses/branding/Sulfur/nsi-installer/RunCmdFile.exe
+rm -fv ./other-licenses/branding/Flock/nsi-installer/install_flash_player.exe
+rm -fv ./other-licenses/branding/Flock/nsi-installer/SetBrowser.EXE
+rm -fv ./other-licenses/branding/Flock/nsi-installer/FLset.exe
+rm -fv ./other-licenses/branding/Flock/nsi-installer/RunCmdFile.exe
+rm -fv ./other-licenses/branding/Flock/installer/photobucket/install_flash_player.exe
+rm -fv ./other-licenses/branding/Flock/installer/photobucket/SetBrowser.EXE
+rm -fv ./other-licenses/branding/Flock/installer/photobucket/FLset.exe
+rm -fv ./other-licenses/branding/Flock/installer/photobucket/RunCmdFile.exe
+rm -fv ./other-licenses/bundled/install_flash_player.exe
+rm -fv ./toolkit/mozapps/installer/windows/nsis/AppAssocReg.dll
+rm -fv ./toolkit/mozapps/installer/windows/nsis/UAC.dll
+rm -fv ./memory/jemalloc/ed.exe
+rm -fv ./flock/base/photo/gm/linux/gm
+rm -fv ./flock/base/photo/gm/osx/ppc/gm
+rm -fv ./flock/base/photo/gm/osx/universal/gm
+rm -fv ./flock/base/photo/gm/osx/i386/gm
+rm -fv ./flock/base/photo/gm/win/gm.exe
+rm -fv ./flock/installer/windows/Processes.dll
+rm -fv ./flock/installer/windows/AppAssocReg.dll
+rm -fv ./flock/installer/windows/UAC.dll
+rm -fv ./flock/installer/windows/7zSD.sfx
+rm -fv ./flock/installer/windows/nsProcess.dll
+rm -fv ./flock/installer/windows/ShellLink.dll
+rm -fv ./flock/installer/windows/time.dll
+rm -fv ./flock/installer/windows/inetc.dll