summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog11
-rw-r--r--src/xpi.mk8
2 files changed, 14 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 657ce37..b5bf494 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,8 @@
mozilla-devscripts (0.11) UNRELEASED; urgency=low
- * [ minefield-packager ] upstream builds are now identified with
- a trailling "-mozilla-central", it's no longer "-trunk"
+ * [ minefield-packager ]
+ upstream builds are now identified with a trailling "-mozilla-central",
+ it's no longer "-trunk"
- update src/minefield-packager.mk.in
* [ mozclient ]
- add support for external project files helping adoption
@@ -17,8 +18,12 @@ mozilla-devscripts (0.11) UNRELEASED; urgency=low
search for $(DEB_BUILDDIR)/mozilla/dist/bin, needed
by mozilla packages using MOZ_OBJDIR
- update src/compare.mk.in
+ * [ xpi ]
+ add support for xpi not located in the root directory. This is needed
+ for extensions built with xulapp.mk
+ - update src/xpi.mk
- -- Fabien Tassin <fta@ubuntu.com> Sat, 20 Sep 2008 01:21:36 +0200
+ -- Fabien Tassin <fta@ubuntu.com> Sat, 27 Sep 2008 19:20:18 +0200
mozilla-devscripts (0.10) intrepid; urgency=low
diff --git a/src/xpi.mk b/src/xpi.mk
index d62dcd2..87a2b3a 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -2,6 +2,7 @@
# Copyright (c) 2008 Canonical Ltd.
# Author(s): Alexander Sack <asac@ubuntu.com>
+# Fabien Tassin <fta@sofaraway.org>
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
@@ -61,6 +62,9 @@ else
XPI_FILE = $(wildcard *.xpi)
endif
+XPI_BASE_FILE = $(notdir $(XPI_FILE))
+XPI_DIR = $(dir $(XPI_FILE))
+
ifneq (,$(MOZ_XPI_EMID))
XPI_EMID = $(MOZ_XPI_EMID)
else
@@ -84,7 +88,7 @@ endif
# ### general helper targets
stamp-unzip-%:
- unzip -d $(TEMPDIR) $*
+ unzip -d $(TEMPDIR) $(XPI_DIR)$*
touch $@
stamp-installdirs-%:
@@ -99,7 +103,7 @@ stamp-install-%: $(foreach mozilla,$(MOZ_XPI_MOZILLA_DIRS),stamp-installdirs-$(m
dh_install -p$(MOZ_EXTENSION_PKG) $(wildcard $(TEMPDIR)/*) /usr/share/$(MOZ_EXTENSION_PKG)
touch $@
-stamp-extension-install: $(XPI_FILE) stamp-unzip-$(XPI_FILE) stamp-install-$(XPI_FILE)
+stamp-extension-install: $(XPI_FILE) stamp-unzip-$(XPI_BASE_FILE) stamp-install-$(XPI_BASE_FILE)
touch $@