summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README5
-rw-r--r--debian/changelog4
-rw-r--r--src/mozclient.mk.in8
3 files changed, 15 insertions, 2 deletions
diff --git a/README b/README
index 4b1dcb4..d66ec1e 100644
--- a/README
+++ b/README
@@ -55,6 +55,11 @@ or
DEBIAN_TAG in the form CVS_TAG=debian_version
ex: DEBIAN_TAG=FIREFOX_3_0b2_RC1=3.0~b2~rc1
+Optionally:
+
+DEBIAN_KEEP_VCS to preserve the VCS files (*/CVS, .hg, ...)
+ ex: DEBIAN_KEEP_VCS=1
+
Projects files are stored in /usr/share/mozilla-devscripts as .mk files.
They contain the following parameters:
diff --git a/debian/changelog b/debian/changelog
index 8df10de..cdfd7bb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -36,6 +36,10 @@ mozilla-devscripts (0.08) UNRELEASED; urgency=low
+ add project xulrunner-2.0 also using Mercurial
- add src/xulrunner-2.0.mk.in
- update src/Makefile
+ + add a variable called DEBIAN_KEEP_VCS to preserve the VCS files such as
+ */CVS or .hg
+ - update src/mozclient.mk.in
+ - update README
-- Fabien Tassin <fta@sofaraway.org> Sat, 19 Apr 2008 14:43:47 +0200
diff --git a/src/mozclient.mk.in b/src/mozclient.mk.in
index 2ace60f..bd3ca83 100644
--- a/src/mozclient.mk.in
+++ b/src/mozclient.mk.in
@@ -28,6 +28,9 @@
# or
# DEBIAN_TAG in the form CVS_TAG=debian_version
# ex: DEBIAN_TAG=FIREFOX_3_0b2_RC1=3.0~b2~rc1
+# Optionally:
+# DEBIAN_KEEP_VCS to preserve the VCS files (*/CVS, .hg, ...)
+# ex: DEBIAN_KEEP_VCS=1
# The following targets are available to the caller:
# - get-orig-source
@@ -92,13 +95,14 @@ MOZCLIENT_PATCHES := ../patches
MOZCLIENT_EXCLUDE_SCRIPT := ../../remove.binonly.sh
NOBINONLY := nobinonly
+TAR_EXCLUDE := $(NULL)
+ifeq (,$(DEBIAN_KEEP_VCS))
ifeq ($(MOZCLIENT_VCS),cvs)
TAR_EXCLUDE := --exclude=CVS --exclude=.cvsignore
else
ifeq ($(MOZCLIENT_VCS),hg)
TAR_EXCLUDE := --exclude=.hg
-else
-TAR_EXCLUDE := $(NULL)
+endif
endif
endif