summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xsrc/med-xpi-pack63
-rwxr-xr-xsrc/med-xpi-unpack58
3 files changed, 123 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4289f19..55d68d7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
mozilla-devscripts (0.10) UNRELEASED; urgency=low
* Open tree for 0.10 development.
+ * Add src/med-xpi-{pack,unpack} scripts to manage packing and unpacking of
+ XPI files.
-- Sasa Bodiroza <jazzva@gmail.com> Tue, 08 Jul 2008 16:23:05 +0200
diff --git a/src/med-xpi-pack b/src/med-xpi-pack
new file mode 100755
index 0000000..53a02f7
--- /dev/null
+++ b/src/med-xpi-pack
@@ -0,0 +1,63 @@
+#!/bin/bash
+
+# Copyright (c) 2008 Alexander Sack, Sasa Bodiroza
+# Description: Script to pack indir to xpifile
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+# The script searches indir for unpacked jar files, which must be located in
+# ./input_dir/path/to/file.jar!/ dir. It will jar it up to
+# ./input_dir/path/to/file.jar, and then remove the contents of unpacked dir.
+# After that, it will zip up the contents of indir to xpi file.
+# Example: med-xpi-pack ubufox.out ubufox-ver.xpi
+
+INDIR=$1;
+XPIFILE=$2;
+
+if [ -z $INDIR ] ; then
+ echo "Missing input directory.";
+ echo "Usage: med-xpi-pack indir xpiname";
+ exit;
+fi;
+if [ -z $XPIFILE ] ; then
+ echo "Missing XPI name.";
+ echo "Usage: med-xpi-pack indir xpiname";
+ exit;
+fi;
+if [ -e $XPIFILE ] ; then
+ echo "E: XPI file already exists.";
+ exit;
+fi;
+if [ ! -d $INDIR ] ; then
+ echo "E: Input directory doesn't exist.";
+ exit;
+fi;
+
+cd $INDIR;
+for JAR_DIR in `find . -type d -name *.jar\!` ; do
+ JAR_FILE=`echo $JAR_DIR | sed "s/jar\!$/jar/"`;
+ ABS_JAR_PATH=`cd $JAR_DIR ; pwd`;
+ ABS_JAR_FILE=`echo $ABS_JAR_PATH | sed "s/jar\!$/jar/"`;
+ pushd $ABS_JAR_PATH > /dev/null;
+ echo "Packing $JAR_FILE";
+ zip -q -r $ABS_JAR_FILE .;
+ popd > /dev/null;
+ rm -rf $ABS_JAR_PATH;
+done;
+cd ..;
+echo "Packing $XPIFILE";
+zip -q -r $XPIFILE $INDIR;
+
+echo "Packed XPI file."
diff --git a/src/med-xpi-unpack b/src/med-xpi-unpack
new file mode 100755
index 0000000..53b8bb1
--- /dev/null
+++ b/src/med-xpi-unpack
@@ -0,0 +1,58 @@
+#!/bin/bash
+
+# Copyright (c) 2008 Alexander Sack, Sasa Bodiroza
+# Description: Script to unpack xpifile to outdir
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+# The script unpacks the xpi file, then searches it for jar files. If it
+# finds any it will unzip it to ./outpur_dir/path/to/file.jar!/ dir.
+# Example: med-xpi-unpack ubufox-ver.xpi ubufox.out
+
+XPIFILE=$1;
+OUTDIR=$2;
+
+if [ -z $XPIFILE ] ; then
+ echo "Missing xpiname directory.";
+ echo "Usage: med-xpi-unpack xpiname outdir";
+ exit;
+fi;
+if [ -z $OUTDIR ] ; then
+ echo "Missing output directory.";
+ echo "Usage: med-xpi-unpack xpiname outdir";
+ exit;
+fi;
+if [ -d $OUTDIR ] ; then
+ echo "E: Output directory already exists.";
+ exit;
+fi;
+if [ ! -e $XPIFILE ] ; then
+ echo "E: XPI file doesn't exist.";
+ exit;
+fi;
+
+mkdir $OUTDIR;
+echo "Unpacking $XPIFILE";
+
+unzip -q $XPIFILE -d $OUTDIR;
+cd $OUTDIR;
+for JAR_PATH in `find . -name *.jar` ; do
+ echo "Unpacking $JAR_PATH";
+ unzip -q $JAR_PATH -d $JAR_PATH!;
+ rm -f $JAR_PATH;
+done;
+cd ..;
+
+echo "Unpacked xpi file.";