summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README6
-rwxr-xr-xsrc/med-xpi-pack4
2 files changed, 3 insertions, 7 deletions
diff --git a/README b/README
index 34e42b2..ca802c5 100644
--- a/README
+++ b/README
@@ -253,11 +253,11 @@ Finally, it will pack the contents of the input directory to the XPI file,
which is placed inside the provided input directory. This behaviour is because
xpi.mk will look for XPI file inside top-level extension directory, which is
the input directory in that case. The script doesn't pack debian/ and temp-*/
-directorie to the XPI file. After XPI file is produced, it will unpack all JAR
+directories to the XPI file. After XPI file is produced, it will unpack all JAR
files, in order to leave intact source.
To run it, pass the name of the input directory, and the name of the XPI file:
$ med-xpi-pack . ubufox.xpi
-In case some of the parameters are missing, input directory doesn't exist, or
-output XPI file already exists, it will report an error and exit.
+In case some of the parameters are missing, or input directory doesn't exist,
+it will report an error and exit.
diff --git a/src/med-xpi-pack b/src/med-xpi-pack
index a44698c..266a77e 100755
--- a/src/med-xpi-pack
+++ b/src/med-xpi-pack
@@ -50,10 +50,6 @@ if [ -z $XPIFILE ] ; then
echo -e "Missing XPI name.\n";
usage;
fi;
-if [ -f $XPIFILE ] ; then
- echo -e "E: XPI file already exists.\n";
- usage;
-fi;
if [ ! -d $INDIR ] ; then
echo -e "E: Input directory doesn't exist.\n";
usage;