summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog12
-rw-r--r--src/lp-locale-export.mk2
2 files changed, 10 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index cf122ea..6ed0615 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,6 @@
mozilla-devscripts (0.14) UNRELEASED; urgency=low
- [ Alexander Sack ]
+ [ Alexander Sack <asac@ubuntu.com> ]
* xpi.mk:
- add target application id magic (|XPI_TARGET_EMIDs|); parse install.rdf
and create extension links for all targetapplications like:
@@ -19,6 +19,9 @@ mozilla-devscripts (0.14) UNRELEASED; urgency=low
- add prism@developer.mozilla.org 1.0 to list of auto detected target
application packages
- update src/xpi.mk
+ - use moz-version --compare in ${xpi:Depends} |CHECK_VERSION| call
+ instead of the rather flawed dpkg --compare-versions approach.
+ - update src/xpi.mk
- add thunderbird-3.0 to list of auto detected target application packages
- update src/xpi.mk
* build-system:
@@ -27,8 +30,11 @@ mozilla-devscripts (0.14) UNRELEASED; urgency=low
accordingly.
- update src/Makefile
- update debian/mozilla-devscripts.install
+ * lp-locale-export.mk:
+ - fix LP: #411191 - webfav lp-locale-export.mk yields en-US.xpi with
+ .manifest files only - fix parsing bug for jar: protocol lines
- [ Benjamin Drung ]
+ [ Benjamin Drung <bdrung@ubuntu.com> ]
* xpi.mk:
- add automatic xpi depends .substvars feature based on smart parsing
of install.rdf and checking min/maxVersion for each target application;
@@ -48,7 +54,7 @@ mozilla-devscripts (0.14) UNRELEASED; urgency=low
binary package listed in debian/control will be used
- update src/xpi.mk
- -- Benjamin Drung <bdrung@ubuntu.com> Thu, 06 Aug 2009 03:26:18 +0200
+ -- Alexander Sack <asac@ubuntu.com> Mon, 10 Aug 2009 01:03:48 +0200
mozilla-devscripts (0.13) unstable; urgency=low
diff --git a/src/lp-locale-export.mk b/src/lp-locale-export.mk
index 3359793..23125fe 100644
--- a/src/lp-locale-export.mk
+++ b/src/lp-locale-export.mk
@@ -56,7 +56,7 @@ MOZCALL_manifest_locale_files_to_outdir = \
localefiles=`cat $(1) | \
grep "^locale[[:space:]]" | \
grep "[[:space:]]$(2)[[:space:]]" | \
- sed -e 's/^.*[[:space:]]$(2)[[:space:]]jar:\(.*\)!.*$$/\1/' | \
+ sed -e 's/^.*[[:space:]][[:space:]]*$(2)[[:space:]][[:space:]]*jar:\(.*\)!.*$$/\1/' | \
sed -e 's/^.*[[:space:]][[:space:]]*$(2)[[:space:]][[:space:]]*\(.*\)$$/\1/' \
`; \
echo "tar -c -C `dirname $(1)`/ -f - $$localefiles \| \