summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile22
-rw-r--r--debian/changelog9
-rw-r--r--debian/compat2
-rw-r--r--debian/control10
-rw-r--r--debian/manpages1
-rwxr-xr-xdebian/rules37
-rw-r--r--src/Makefile15
7 files changed, 42 insertions, 54 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..93207d8
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,22 @@
+PREFIX ?= /usr
+DOCDIR ?= $(PREFIX)/share/doc/mozilla-devscripts
+MANDIR ?= $(PREFIX)/share/man
+
+MANPAGES := $(wildcard man/*.1)
+
+build:
+ $(MAKE) -C src $@
+
+test:
+ tests/test-moz-version
+
+install:
+ install -d $(DESTDIR)$(DOCDIR) $(DESTDIR)$(MANDIR)/man1
+ install $(MANPAGES) $(DESTDIR)$(MANDIR)/man1/
+ install -m 644 README $(DESTDIR)$(DOCDIR)/README
+ $(MAKE) -C src $@
+
+clean:
+ $(MAKE) -C src $@
+
+.PHONY: build clean install test
diff --git a/debian/changelog b/debian/changelog
index 46b040a..e9a7017 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,8 +8,15 @@ mozilla-devscripts (0.25) UNRELEASED; urgency=low
- update src/xul-app-data.csv.Ubuntu
* Drop backwards compatibility for Icedove/Thunderbird << 3.0.
- update src/install-xpi
+ * Switch from CDBS to dh 7 and simplifying packaging by improving Makefiles.
+ - add Makefile
+ - update debian/compat
+ - update debian/control
+ - remove debian/manpages
+ - update debian/rules
+ - update src/Makefile
- -- Benjamin Drung <bdrung@ubuntu.com> Tue, 16 Nov 2010 00:07:17 +0100
+ -- Benjamin Drung <bdrung@ubuntu.com> Tue, 16 Nov 2010 01:35:04 +0100
mozilla-devscripts (0.24) unstable; urgency=low
diff --git a/debian/compat b/debian/compat
index 7ed6ff8..7f8f011 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-5
+7
diff --git a/debian/control b/debian/control
index 2ef920c..2a0c057 100644
--- a/debian/control
+++ b/debian/control
@@ -6,8 +6,8 @@ Uploaders: Fabien Tassin <fta@ubuntu.com>,
Alexander Sack <asac@debian.org>,
Alexander Sack <asac@ubuntu.com>,
Benjamin Drung <bdrung@ubuntu.com>
-Build-Depends: cdbs, debhelper (>= 5)
-Build-Depends-Indep: python, python-support
+Build-Depends: debhelper (>= 7), python
+Build-Depends-Indep: python-support
Standards-Version: 3.9.1
DM-Upload-Allowed: yes
Homepage: https://launchpad.net/mozilla-devscripts
@@ -26,10 +26,8 @@ Depends: dpkg-dev,
${misc:Depends},
${perl:Depends},
${python:Depends}
-Suggests: cvs,
- git-core,
- mercurial
+Suggests: cvs, git, mercurial
Description: Collection of dev scripts used by Ubuntu Mozilla packages
This package contains mozilla-devscripts, a collection of scripts
based on Makefile inheritance which provides targets usable by Mozilla
- packages in Ubuntu and Debian
+ packages in Ubuntu and Debian.
diff --git a/debian/manpages b/debian/manpages
deleted file mode 100644
index bf519d7..0000000
--- a/debian/manpages
+++ /dev/null
@@ -1 +0,0 @@
-man/*.1
diff --git a/debian/rules b/debian/rules
index 8285ed4..2d33f6a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,37 +1,4 @@
#!/usr/bin/make -f
-# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
-DEB_SOURCE_PACKAGE := $(shell dpkg-parsechangelog | sed -n 's/^Source: *\(.*\)$$/\1/ p')
-DEB_VERSION := $(shell dpkg-parsechangelog | sed -n 's/^Version: *\(.*\)$$/\1/ p')
-DEB_ISNATIVE := 1
-
-DEB_INDEP_PACKAGES = $(DEB_SOURCE_PACKAGE)
-DEB_ARCH_PACKAGES = $(NULL)
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/makefile.mk
-
-DEB_SRCDIR := $(CURDIR)/src
-DEB_MAKE_BUILD_TARGET := build
-DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(CURDIR)/debian/mozilla-devscripts/
-DEB_MAKE_CHECK_TARGET := test
-
-DEB_INSTALL_DOCS_ALL := README
-
-install/mozilla-devscripts::
- dh_pysupport
+%:
+ dh $@
diff --git a/src/Makefile b/src/Makefile
index b89a80a..f5f909e 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -19,8 +19,6 @@
PREFIX ?= /usr
BINDIR ?= $(PREFIX)/bin
-MANDIR ?= $(PREFIX)/share/man
-
DATADIR = $(PREFIX)/share/mozilla-devscripts
VENDOR := $(shell if dpkg-vendor --is Ubuntu || dpkg-vendor --derives-from Ubuntu; then echo "Ubuntu"; else echo "Debian"; fi)
@@ -69,6 +67,8 @@ extra_dirs = \
minefield-packager/debian \
$(NULL)
+build: $(subst_files)
+
%.mk: %.mk.in
cat $< | sed \
-e "s|^\(include\) \(.*\)\.in|\1 $(DATADIR)/\2|" \
@@ -78,11 +78,6 @@ extra_dirs = \
> $@
chmod 644 $@
-build: $(subst_files)
-
-test:
- ../tests/test-moz-version
-
install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(dir)/*))
install -m 755 -d $(DESTDIR)$(DATADIR) $(foreach dir,$(extra_dirs),$(DESTDIR)$(DATADIR)/$(dir))
install -m 644 $(subst_files) $(extra_files) $(DESTDIR)$(DATADIR)
@@ -99,10 +94,10 @@ install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(
find $(DESTDIR)$(DATADIR) -type f \( -name \*.pl -o -name \*.sh \) -exec chmod -v 755 {} \;
chmod 755 $(DESTDIR)$(DATADIR)/minefield-packager.mk
install -m 644 xul-app-data.csv.$(VENDOR) $(DESTDIR)$(DATADIR)/xul-app-data.csv
- install -D -m 644 xul-ext.pm $(DESTDIR)/usr/share/perl5/Debian/Debhelper/Sequence/xul_ext.pm
- install -D -m 644 xul-ext_build.pm $(DESTDIR)/usr/share/perl5/Debian/Debhelper/Buildsystem/xul_ext.pm
+ install -D -m 644 xul-ext.pm $(DESTDIR)$(PREFIX)/share/perl5/Debian/Debhelper/Sequence/xul_ext.pm
+ install -D -m 644 xul-ext_build.pm $(DESTDIR)$(PREFIX)/share/perl5/Debian/Debhelper/Buildsystem/xul_ext.pm
clean:
rm -f $(subst_files)
-.PHONY: clean install test
+.PHONY: clean install