summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/control2
-rwxr-xr-xsrc/dh_xul-ext6
2 files changed, 4 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index 60c436d..a16e6a8 100644
--- a/debian/control
+++ b/debian/control
@@ -19,7 +19,7 @@ Depends: dpkg-dev,
fakeroot,
libxml-xpath-perl,
python,
- python-rdflib
+ python-rdflib,
quilt,
unzip,
wget,
diff --git a/src/dh_xul-ext b/src/dh_xul-ext
index e9c4276..4446966 100755
--- a/src/dh_xul-ext
+++ b/src/dh_xul-ext
@@ -45,16 +45,16 @@ def get_xul_apps():
if line == "\n":
if xul_appid is not None:
# find duplicates and keep older version
- found_duclicate = False
+ found_duplicate = False
for i in xrange(len(packages) - 1, -1, -1):
if packages[i][0] == package_name:
command = ['dpkg', '--compare-versions', version, 'lt', packages[i][1]]
if subprocess.call(command) == 0:
del packages[i]
else:
- found_duclicate = True
+ found_duplicate = True
break
- if not found_duclicate:
+ if not found_duplicate:
packages.append([package_name, version, xul_appid, xul_eol])
package_name = None
version = None