summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README3
-rw-r--r--debian/changelog2
-rw-r--r--src/mozclient/flock.conf2
-rw-r--r--src/mozclient/lib/MozClient/VCS.pm5
4 files changed, 5 insertions, 7 deletions
diff --git a/README b/README
index cd50382..f1ed9e9 100644
--- a/README
+++ b/README
@@ -83,7 +83,8 @@ as .conf files. They contain the following parameters:
- MOZCLIENT_GETVERSION (mandatory): how to transform the version
- MOZCLIENT_GETDATE (mandatory): get the last commit date for the project
- MOZCLIENT_SEPARATOR (optional): separator between version and date (default: ~)
-- MOZCLIENT_TAREXCLUDE (optional): list of dirs/files to exclude from packaging
+- MOZCLIENT_TAREXCLUDE (optional): list of additional dirs/files to exclude
+ from packaging
- MOZCLIENT_EMBEDDED (optional): create an embedded tarball (default: 0)
- MOZCLIENT_WANTMOZDIR (optional): should the root dir be 'mozilla'?
(default: 0 unless MOZCLIENT_EMBEDDED=1)
diff --git a/debian/changelog b/debian/changelog
index c116937..e77e864 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -49,7 +49,7 @@ mozilla-devscripts (0.09) UNRELEASED; urgency=low
- update src/Makefile
- update src/mozclient/mozclient.pl
- update src/mozclient/lib/MozClient/VCS.pm
- + add optional MOZCLIENT_TAREXCLUDE to overwrite the list of dirs/files
+ + add optional MOZCLIENT_TAREXCLUDE to extend the list of dirs/files
to exclude from packaging
- update src/mozclient/lib/MozClient/VCS.pm
- update src/mozclient/mozclient.pl
diff --git a/src/mozclient/flock.conf b/src/mozclient/flock.conf
index e0d6c03..53bf86e 100644
--- a/src/mozclient/flock.conf
+++ b/src/mozclient/flock.conf
@@ -24,4 +24,4 @@ MOZCLIENT_GETVERSION = sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/' mozilla/flo
MOZCLIENT_GETDATE = svn log --xml --limit 1 svn://svn-mirror.flock.com/master/flock/trunk/mozilla | grep -E '^( *revision=|<date>)' | tr -d '\n' | sed -e 's/.*"\([0-9]*\)".*>\(....\)-\(..\)-\(..\)T.*/\2\3\4r\1/'
MOZCLIENT_EMBEDDED = 1
MOZCLIENT_WANTMOZDIR = 0
-MOZCLIENT_TAREXCLUDE = .svn CVS .cvsignore
+MOZCLIENT_TAREXCLUDE = CVS .cvsignore
diff --git a/src/mozclient/lib/MozClient/VCS.pm b/src/mozclient/lib/MozClient/VCS.pm
index 4434ca8..d97e45c 100644
--- a/src/mozclient/lib/MozClient/VCS.pm
+++ b/src/mozclient/lib/MozClient/VCS.pm
@@ -308,15 +308,12 @@ sub pack {
my $tar_exclude = "";
unless ($self->{'preserve_vcs'}) {
- my $dirs;
+ my $dirs = $self->tar_exclude();;
if (defined $self->{'MOZCLIENT_TAREXCLUDE'}) {
for my $item (@{$self->{'MOZCLIENT_TAREXCLUDE'}}) {
push @$dirs, "--exclude $item";
}
}
- else {
- $dirs = $self->tar_exclude();
- }
$tar_exclude = join " ", @$dirs;
}