summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--man/moz-version.149
-rw-r--r--src/Makefile8
3 files changed, 61 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 489c171..774690d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -15,8 +15,12 @@ mozilla-devscripts (0.15) UNRELEASED; urgency=low
* lp-locale-export.mk:
- remove shebang
- update src/lp-locale-export.mk
+ * moz-version:
+ - wrote man page for moz-version
+ - add man/moz-version.1
+ - update src/Makefile
- -- Benjamin Drung <bdrung@ubuntu.com> Tue, 11 Aug 2009 23:50:45 +0200
+ -- Benjamin Drung <bdrung@ubuntu.com> Wed, 12 Aug 2009 02:14:30 +0200
mozilla-devscripts (0.14) unstable; urgency=low
diff --git a/man/moz-version.1 b/man/moz-version.1
new file mode 100644
index 0000000..bd820fd
--- /dev/null
+++ b/man/moz-version.1
@@ -0,0 +1,49 @@
+.\"Copyright (c) 2009 Benjamin Drung <bdrung@ubuntu.com>
+.\"
+.\"Permission is hereby granted, free of charge, to any person obtaining a copy
+.\"of this software and associated documentation files (the "Software"), to deal
+.\"in the Software without restriction, including without limitation the rights
+.\"to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+.\"copies of the Software, and to permit persons to whom the Software is
+.\"furnished to do so, subject to the following conditions:
+.\"
+.\"The above copyright notice and this permission notice shall be included in
+.\"all copies or substantial portions of the Software.
+.\"
+.\"THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+.\"IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+.\"FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+.\"AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+.\"LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+.\"OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+.\"THE SOFTWARE.
+.TH MOZ-VERSION "1" "August 2009" "moz-version" "mozilla-devscripts suite"
+.SH NAME
+moz-version \- version format handling tool
+.SH SYNOPSIS
+.B moz-version
+[\fIoptions\fP]
+\fI--compare ver1 comparator ver2\fR
+.SH DESCRIPTION
+.B moz-version
+is a tool for working with version string from the Mozilla suite.
+Currently it can only compare versions.
+.SH ACTIONS
+.TP
+.B \-\-compare \fIver1 comparator ver2\fP
+Compare version numbers, where \fIcomparator\fP is a binary operator.
+\fBmoz-version\fP returns success (zero result) if the specified condition is
+satisfied, and failure (nonzero result) otherwise. The comparator must be one of
+\fBlt le eq ne ge gt\fP.
+.SH OPTIONS
+.TP
+\fB\-h\fR, \fB\-\-help\fR
+Display a brief help message.
+.TP
+\fB\-s\fR, \fB\-\-silent\fR
+Do not print anything and die silent on errors.
+.TP
+\fB\-v\fR, \fB\-\-verbose\fR
+Print more information.
+.SH AUTHOR
+Benjamin Drung <bdrung@gmail.com>
diff --git a/src/Makefile b/src/Makefile
index ae7281d..3149cc6 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -19,6 +19,7 @@
PREFIX ?= /usr
BINDIR ?= $(PREFIX)/bin
+MANDIR ?= $(PREFIX)/share/man
DATADIR = $(PREFIX)/share/mozilla-devscripts
@@ -74,7 +75,7 @@ extra_dirs = \
build: $(subst_files)
-install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(dir)/*))
+install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(dir)/*)) install-man
install -m 755 -d $(DESTDIR)$(DATADIR) $(foreach dir,$(extra_dirs),$(DESTDIR)$(DATADIR)/$(dir))
install -m 644 $(subst_files) $(extra_files) $(DESTDIR)$(DATADIR)
install -m 755 -d $(DESTDIR)$(BINDIR)
@@ -85,5 +86,10 @@ install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(
find $(DESTDIR)$(DATADIR) -type f \( -name \*.pl -o -name \*.sh \) -exec chmod -v 755 {} \;
chmod 755 $(DESTDIR)$(DATADIR)/minefield-packager.mk
+install-man:
+ install -D -m 644 ../man/moz-version.1 $(DESTDIR)$(MANDIR)/man1/moz-version.1
+
clean:
rm -f $(subst_files)
+
+.PHONY: clean install install-man