summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README18
-rw-r--r--debian/changelog6
-rw-r--r--src/mozclient.mk.in8
3 files changed, 31 insertions, 1 deletions
diff --git a/README b/README
index ca802c5..96be739 100644
--- a/README
+++ b/README
@@ -49,6 +49,24 @@ To use :
- in debian/control: add mozilla-devscripts to Build-Depends
- in debian/rules: add "include /usr/share/mozilla-devscripts/yourproject.mk"
+Note: it is also possible to keep all project files outside of mozilla-devscripts.
+To do so, mozclient needs two variables:
+- MOZCLIENT_PROJECTNAME: the name of the conf file as described below, without the
+ ".conf" extension
+- MOZCLIENT_PROJECTDIR: a directory containing the project specific files to be used
+ by mozclient. It is not a recommended to use the debian directory directly because
+ there will be a confusion between debian/patches and $(MOZCLIENT_PROJECTDIR)/patches
+
+ex:
+ in debian/rules:
+ MOZCLIENT_PROJECTNAME = myproject
+ MOZCLIENT_PROJECTDIR = debian/mozclient
+ include /usr/share/mozilla-devscripts/mozclient.mk
+ in debian/mozclient:
+ - a mandatory file called myproject.conf
+ - an optional patches directory
+ - an optional myproject-remove.binonly.sh file
+
The following targets are then available to the caller of debian/rules:
- get-orig-source
Build a tarball according to parameters from project.mk
diff --git a/debian/changelog b/debian/changelog
index fbcd9be..4f56f8e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,8 +3,12 @@ mozilla-devscripts (0.11) UNRELEASED; urgency=low
* [ minefield-packager ] upstream builds are now identified with
a trailling "-mozilla-central", it's no longer "-trunk"
- update src/minefield-packager.mk.in
+ * [ mozclient ] add support for external project files helping adoption
+ of mozilla-devscripts by downstream. Introduce MOZCLIENT_PROJECTDIR.
+ - update README
+ - update src/mozclient.mk.in
- -- Fabien Tassin <fta@ubuntu.com> Wed, 17 Sep 2008 15:29:04 +0200
+ -- Fabien Tassin <fta@ubuntu.com> Wed, 17 Sep 2008 19:50:07 +0200
mozilla-devscripts (0.10) intrepid; urgency=low
diff --git a/src/mozclient.mk.in b/src/mozclient.mk.in
index 3c4b747..5613585 100644
--- a/src/mozclient.mk.in
+++ b/src/mozclient.mk.in
@@ -53,6 +53,14 @@ ifdef MOZ_CO_MODULE
ARGS += -m $(MOZ_CO_MODULE)
endif
+ifdef MOZCLIENT_PROJECTDIR
+ ARGS += -c $(MOZCLIENT_PROJECTDIR)
+endif
+
+ifeq (,$(MOZCLIENT_PROJECTNAME))
+$(error You must specify MOZCLIENT_PROJECTNAME)
+endif
+
list-tags:
perl $(MOZDEVSCRIPT_DIR)/mozclient.pl$(EXT) -l $(MOZCLIENT_PROJECTNAME)